Fix CPU Name with RestrictEvents

AMDPUSH

Member
Joined
May 2, 2020
Messages
103
Try 3841 for the 3950X.
I don't understand why i should put a number, with 0 it's working.
Can you explain why i should put 3841 ?
 

Attachments

  • Screen Shot 2021-05-05 at 20.08.08.png
    Screen Shot 2021-05-05 at 20.08.08.png
    71.6 KB · Views: 11

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
911
I don't understand why i should put a number, with 0 it's working.
Can you explain why i should put 3841 ?

If it’s working with 0 then you don’t need to put anything.
 

grad1e

New member
Joined
Jan 8, 2021
Messages
9
Em, guys, I got confused.
I added the kext to the folder and then added it to config.plist and yet it shows Unknown. Is there anything else to do?
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
617
@grad1e If your CPU is shown as Unknown then this kext won't fix that. You'd have to set ProcessorType to 1537 in your config.plist for a six core.

@AMDPUSH you don't have to set it if your CPU does not show up as Unknown, you can leave it at 0.
 

grad1e

New member
Joined
Jan 8, 2021
Messages
9
@grad1e If your CPU is shown as Unknown then this kext won't fix that. You'd have to set ProcessorType to 1537 in your config.plist for a six core.

@AMDPUSH you don't have to set it if your CPU does not show up as Unknown, you can leave it at 0.
So for setting PrcoessorType, is this kext necessary or can I do that without the kext?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
815
So for setting PrcoessorType, is this kext necessary or can I do that without the kext?
If you want the system to show your AMD CPU info in about this Mac then set processor type to 1537 and use the kext.
If you don’t want it to display your amd info and instead show as a Intel cpu set processor type to 1537 and don’t use the kext.
 

grad1e

New member
Joined
Jan 8, 2021
Messages
9
If you want the system to show your AMD CPU info in about this Mac then set processor type to 1537 and use the kext.
If you don’t want it to display your amd info and instead show as a Intel cpu set processor type to 1537 and don’t use the kext.
Screenshot 2021-05-07 at 18.09.44.png
Awesome. Thx mahn
 

vk2emp

Member
Joined
May 17, 2020
Messages
34
I was just browsing topics in this subforum and this bugs me no end, "Intel Xeon W". Dropping this kext in to the kexts folder and referencing it in config.plist worked a treat. My cpu now shows up as the correct model (AMD Ryzen 3700X).
 
Top Bottom