AudioGod's ASUS ROG STRIX X570-E GAMING - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

whatevergreen

New member
Joined
Oct 5, 2021
Messages
2
I have the Dark Hero motherboard. WiFi worked on Big Sur but on Monterey it stopped working altogether. I made sure I installed OpenIntelWireless correctly as well, as before. Anyone here have working wifi? The device isn't even being recognized at all.

Funny enough, when I use HeliPort, I see my wireless networks and it does connect correctly, but as soon as I unplug the ethernet cable from the 2.5G LAN port the wireless goes out as well.
DO yourself a favor and replace the WIFI + Bluetooth combo with this (40€) https://www.ebay.de/itm/174776123154?var=473952088627 will work out of the box and you will have a easier life. the intel chipset and the intel wireless driver never worked 100% properly and probably never will.

Thanks @AudioGod for providing this efi and the work you have done in this. i hope you stay with this mainboard for some time.
 

thisisgm

New member
Joined
Sep 2, 2021
Messages
6
Does anyone know if the new ROG STRIX X570-E GAMING WIFI II is the same as the one AudioGod has, the X570-E (old model)? I have an M.2 Wi-Fi card installed on my TUF X570 Pro and I'm experiencing massive mouse lag issues in windows and mac with this motherboard, want to replace it with one that works flawless with this guide using that same card, sort of "plug & play", let me know!
 

Pabo

Member
Joined
Sep 2, 2020
Messages
45
Does anyone know if the new ROG STRIX X570-E GAMING WIFI II is the same as the one AudioGod has, the X570-E (old model)? I have an M.2 Wi-Fi card installed on my TUF X570 Pro and I'm experiencing massive mouse lag issues in windows and mac with this motherboard, want to replace it with one that works flawless with this guide using that same card, sort of "plug & play", let me know!
Here #669
 

Ezaul

Member
Joined
Apr 21, 2021
Messages
26
OpenCore 0.7.6 EFI Update , 6th December 2021

The EFI has now been updated to the my latest version.
Changes made include,
  • Lilu 1.5.8,
  • AppleALC 1.6.7,
  • WhateverGreen 1.5.5,
  • VirtualSMC 1.2.8,
  • RestrictEvents 1.0.5,
  • LucyRTL8125Ethernet 1.1.0
  • SMCAMDProcessor 0.7
  • SmallTreeIntel812576Ethernet 1.3.0
  • New Universal AMD Patches Monterey 12.0 Compatible,
  • 2.5Ghz Ethernet Auto Negotiation Fixed,
  • Memory Mapping is now Being done via RestrictEvents,
  • About This Mac now displays the correct AMD Processor info done via RestrictEvents,
  • Plus other minor tweaks and changes to the config.
Note 1 - If your not using a RX 6800 or any other Navi/BigNavi GPU then remove agdpmod=ignore from the boot arguments.

Note 2 - If you are using a 6 or Less Core Ryzen then go into the Config,plist and under PlatformInfo->Generic Change the ProcessorType from 0 to 1537, This will list your CPU info correctly inside About This Mac.

Note 3 - The SmallTreeIntel82576.kext is now fully working as of Monterey 12.0 Beta 8

Note 4 - BIOS SETTING CHANGE - Since Bios Revision 4010 Power On By PCIe can break shut down on some peoples builds so ensure the following setting is now set as disabled.
  • Advanced -> APM Configuration -> Power On By PCIe -> Disabled

For OpenCore Using PlistEdit Pro add your details by modifying the following
1627932237694.png





IMPORTANT PATCH INFO TO SET THE CORRECT CORE COUNT FOR YOUR CPU
Core Count patch needs to be modified to boot your system. Find the two algrey - Force cpuid_cores_per_package patches and alter the Replace value only.

Changing BA000000 0000/BA000000 0090* to BA <CoreCount> 0000 0000/BA <CoreCount> 0000 0090* substituting <CoreCount> with the hexadeciamal value matching your physical core count.

Note: The three different values reflect the patch for different versions of macOS. Be sure to change all three if you boot macOS 10.13 to macOS 12

See the table below for the values matching your CPU Core Count.

CoreCountHexadecimal
6 Core06
8 Core08
12 Core0C
16 Core10
32 Core20
So for example a 6 Core 5600X would result in these replace values, BA 06 0000 0000/BA 06 0000 0090
Or a 12 Core 5900X that I have it setup as standard would result in these replace values, BA 0C 0000 0000/BA 0C 0000 0090

EXAMPLE
Screenshot 2021-08-02 at 19.51.06.png



Power Gadget App
The AMDRyzenCPUPowerManagement.kext has been updated and has gone from good to Amazing so make sure you download the latest version of the Power Gadget App to make the most of it.
AMD.Power.Gadget.app.zip

Finally and as always, MAKE SURE YOU RESET YOUR NVRAM BEFORE BOOTING INTO THE NEW EFI.


OpenCore EFI Update V0.7.6 - 06/12/2021
 

Attachments

  • Asus X570-E 076 EFI .zip
    5.8 MB · Views: 75

Ezaul

Member
Joined
Apr 21, 2021
Messages
26
Hello! I would like to ask our great master AUDIOGOD for a license, as I realized that no one else continued to update opencore for ROG STRIX X570-E GAMING I took the liberty of posting the EFI for the latest version here, following the same posting pattern as AUDIOGOD
 

marinekev88

Member
Joined
Oct 23, 2021
Messages
46
@Shaneee do you remember if the USB mapping on the strix-e is the same as the Hero/Dark Hero ? The my other post you recommended dropping the network negotiation down to 1000 base T and if that doesn't work then it looks like the kexts in 0.7.6oc get things going again.

I'm going to ask a super noob question but to confirm upgrading from 0.7.4 to 0.7.6 should be as simple as pulling down the efi > input my device spec data > unhide the system efi directory and swap out for the new one > reboot and clear nvram > and done?

Sent from my SM-N986U using Tapatalk
 

johnlietzke

Active member
Joined
Jul 7, 2021
Messages
140
Ezaul, thank you for the updated EFI. Super easy and works perfectly.

I think AudioGod will appreciate it. He is not the type of guy who would be petty enough to ask for a license.

Thank you again.
 
Last edited:

johnlietzke

Active member
Joined
Jul 7, 2021
Messages
140
Here is a different version of Ezaul's excellent EFI with the CPU, GPU and fan sensors that work with iStat Menus.

Install and set the Core Count and Platform Info the same way. If your not using a RX 6800 or any other Navi/BigNavi GPU then remove agdpmod=ignore from the boot arguments. Make sure to reset the NVRAM.

The AMD Power Gadget will prompt you to update the kext. The only way to get the CPU temperature to show up in iStat Menus is to use an older version of SMCAMDProcessor kext. But the AMD Power Gadget can be disabled at log since you now have the temperature in iStat Menus sensor list.
 

Attachments

  • EFI.zip
    8.5 MB · Views: 21
Last edited:

gatorchamp85

New member
Joined
Jul 27, 2021
Messages
19
@Ezaul - very helpful update, this is much appreciated.

I haven't been following along much, but on 0.7.6 are we able to turn on Resize BAR?
 

gatorchamp85

New member
Joined
Jul 27, 2021
Messages
19
Updated to the Ezaul 0.7.6 EFI and all is working well. Updated to 12.1 this morning without issue.

Nice to have SAM available on Windows for gaming without changing settings in the BIOS!
 

johnlietzke

Active member
Joined
Jul 7, 2021
Messages
140
Not really much benefit in MacOS unless you are gaming. But it makes a big difference having it enabled for gaming in Windows.


Sent from my iPhone using Tapatalk
 

marinekev88

Member
Joined
Oct 23, 2021
Messages
46
Not really much benefit in MacOS unless you are gaming. But it makes a big difference having it enabled for gaming in Windows.


Sent from my iPhone using Tapatalk
I don't really game and if I feel like some Doom play then I pull my windows laptop out.. so that saves me the config change. Thanks

Sent from my SM-N986U using Tapatalk
 

kouchangyin

New member
Joined
Dec 11, 2021
Messages
8
This is my computer configuration. Can I use your EFI file?
  • CPU: Ryzen 5 3600X
  • Motherboard: Asus ROG CROSSHAIR VII HERO (WI-FI)X470 platform
  • RAM: 16GB DDR4 3200MHz
  • Graphics: SAPPHIRE Radeon R7 240(Graphics cards can be ignored.)
  • HDD: SAMSUNG 970EVO 500GB
 

vitorpvcampos

New member
Joined
May 4, 2020
Messages
21
Here is a different version of Ezaul's excellent EFI with the CPU, GPU and fan sensors that work with iStat Menus.

Install and set the Core Count and Platform Info the same way. If your not using a RX 6800 or any other Navi/BigNavi GPU then remove agdpmod=ignore from the boot arguments. Make sure to reset the NVRAM.

The AMD Power Gadget will prompt you to update the kext. The only way to get the CPU temperature to show up in iStat Menus is to use an older version of SMCAMDProcessor kext. But the AMD Power Gadget can be disabled at log since you now have the temperature in iStat Menus sensor list.
I used this EFI and updated to Monterey but booting is taking forever... any tips?
(to activate verbose mode during boot, do I have to add -v to boot arguments, right?)
 
Top Bottom