SUCESS HUAWEI Laptop Matebook 13 2020 ryzen 5 3500u

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi all,

I´m trying to build a ryzintosh on my laptop with the following specifications:

HUAWEI LAPTOP MATEBOOK 13 2020 Ryzen 5 3500u with Radeon Vega 8 Graphics (1GB)

CPU AMD RYZEN 5 3500U, 2400MHZ
MOTHER BOARD: HUAWEI HN-WX9X-PCB VERSION M110
CHIPSET MOTHER BOARD: AMD K17.1 FCH, AMD K17.1 IMC
GRAPHICS: INTEGRATED AMD RADEON VEGA 8 GRAPHICS (1GB).
ADAPTER 3D: AMD PICASSO

MULTIMEDIA:

AUDIO ADAPTER: AMD K17.1
AUDIO ADAPTER: ATI RADEON HDMI @ AMD K17.1 DISPLAY HIGH DEFINATION AUDIO CONTROLLER
AUDI ADAPTER: REALTEK ALC256 @ AMD K17.1 HIGH DEFINITION AUDIO CONTROLLER

NVMe: SAMSUNG MZVB512HAJQ-0000 (512 GB, PCI=E 3.0 x4

kEYBOARD: PS/2 standar
MOUSE: COMPATIBLE WITH HID

NETWORK
WIFI ADAPTER: REALTECK 8822CE

USB: 2XUSB3 CONTROLLER AMD K17.1 USB 3.1 xHCI CONTROLLER

BIOS: VERSION 1.17

With my current EFI files the system start booting at apple´s logo but the progress bar dees not progresses. I can see the mouse cursor and I can move it, but that is all. I´ve tried with macos Monterey 12.6.8 and also with Ventura 13.6 with the same result.

Any comments or suggestions to keep on are wellcome.

Thanks in advance for your recommendations.
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
HI there,

I have checked this out from the OC installation´s guide, with the same result.

Frozen in the macOS installer after 30 seconds

This is likely due to faulty or outright missing NullCPUPowerManagement, the one hosted on AMD OSX's Vanilla Guide is corrupted. Go yell at Shannee to fix it. To fix the issue, remove NullCPUPowerManagement from Kernel -> Add and EFI/OC/Kexts then enable DummyPowerManagement under Kernel -> Emulate

Anybody that could give me a hit to continue throbleshutting this issue ?.

Thanks in advance for your remarks.
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi there again,

This is the error reported by open core at the end of a text file at EFI partition:

AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"usr\\standalone\\OS.dmg.root_hash">
85:721 00:252 AAPL: #[EB.RH.LRH|P!] Err(0xE) <- EB.LD.LF
86:678 00:956 AAPL: #[EB.BST.FBS|!] Err(0xE) <- EB.RH.LRH
86:928 00:250 AAPL: #[EB.B.WFDW|!WF] Err(0xE) 0
87:865 00:936 AAPL: #[EB|LOG:DT] 2023-09-29T16:20:38
88:143 00:278 AAPL: #[EB|LOG:EXITBS:START] 2023-09-29T16:20:38

I´ve been trying the recomendations on the OC throubleshooting guide and searching on internet, making changes and testing without sucess.

Anybody can give me a sugestion to keep on trying ?

Thanks!
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi,

Anybody can help me out ?

The macos installer (Monterey/Ventura) is booting to lenguage selection. I can chose and hit enter but the booting does not keep on looding. I´ve got an empty screen with the mouse cursor which i can move, but that is all.

Any recomendation is wellcome.

Thanks
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi there,

A little step forward, now I get to the installation menu but, when I select to install macos (monterey or ventura) I get the message that I need to have and internet connexion. I have wifi from my laptop but don´t know how to setup it up so, I also connected a dongle with ethernet port for wired connection but, It is not working either.

Any idea to solve this issue is wellcome.

Regards
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi,

I´ll try with my Android phone, using USB with HoRNDIS, and see what happen.
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi there,

Up and runnig with macos ventura.

Thanks a lot a this community for making this to happen.
 

redhorse1990

Member
AMD OS X Member
Joined
Jul 2, 2022
Messages
115
Hi there again,

This is the error reported by open core at the end of a text file at EFI partition:

AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"usr\\standalone\\OS.dmg.root_hash">
85:721 00:252 AAPL: #[EB.RH.LRH|P!] Err(0xE) <- EB.LD.LF
86:678 00:956 AAPL: #[EB.BST.FBS|!] Err(0xE) <- EB.RH.LRH
86:928 00:250 AAPL: #[EB.B.WFDW|!WF] Err(0xE) 0
87:865 00:936 AAPL: #[EB|LOG:DT] 2023-09-29T16:20:38
88:143 00:278 AAPL: #[EB|LOG:EXITBS:START] 2023-09-29T16:20:38

I´ve been trying the recomendations on the OC throubleshooting guide and searching on internet, making changes and testing without sucess.

Anybody can give me a sugestion to keep on trying ?

Thanks!
How did you fix this problem and get through
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi there,

I had many isssues, which one are you interested in ?
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
Hi,

In this moment I have another one, that so far I´ve got no clue, my goal was to have macos on the laptop with a broken display.

I have two identical laptops, one of them with a broken display. I did remove the broken display and the nvme ssd. I put the nvme ssd on a usb adapter and installed the macos ventura on it on the other laptop (with no broken display), I have two usb dongles with usb ports, hdmi and one of them with ethernet port. I have access to internet thru that port and i can replicate the main macos window on and external monitor thru hdmi port. From that point, I put back the nvme ssd on the laptop with a broken display and does not boot (securete boot on bios is disable). Then I tried to boot using the usb adapter and does not boot either. I tried to reset NVRAM by cliking twice the right arrow and enter (on the external monitor i have no image), but same result.

With windows and linux (ubuntu distribution) both OS can boot without any issue, i have tested thru external usb adapter as well.

Any idea is wellcome.
 

jre2706

New member
AMD OS X Member
Joined
Sep 27, 2023
Messages
17
How did you fix this problem and get through
Hi there,
Regarding that particular issue, on my case, the booting process was waiting on apple’ s GUI to choose the language, my problem was that I had a black screen. I had one dongle on the left usb port and another one on the right usb port. I was unpluging the HDMI cable from my external monitor, when suddenly I had the apple’s GUI on the screen, which stayed on regarless plugging in the HDMI cable back.
 
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.