Ryzen 3900x - Asus X370-i - USB mapping issues and strange behaviour


New member
AMD OS X Member
Sep 14, 2020
HI ! After getting a GTX1080 to replace my RX580 (I needed the CUDA cores to work) I had to downgrade from 10.15 Catalina to 10.13.6 High Sierra and that's where trouble started.
Before getting into the issue I should state that the system was amazingly stable on Catalina and everything worked as expected.

Now in High Sierra I'm getting a strange USB behaviour. When I plug a USB Hub into one of the 3.0 ports it doesn't work but when plugged into 3.1 port it does. The same thing happens with my USB audio interface (Audient ID44), but when it works I'm getting crackles and unstable audio.

So I tried to USB map my ports and I noticed a few things were off.
First I'm missing some ports in the XHC0 controller even though I have mapped them and they are present in the DSDT. (PRT5 to 8)
Second, some ports have dual personalities 2.0/3.0 as expected, and some only have one : whether I plug a 2.0 or 3.0 device the same port lights up in IOReg. This happens on both the XHC0 and PTXH controller.

I've been banging my head on this for a few days but can't figure out what's wrong.

Here are some screenshots. I'm also attaching the DSDT, EFI and USBMap kext.

(Ports PO18 and PO20 are missing because I removed them, they are Bluetooth and Asus' RGB controller which I don't need)

Screen Shot 2020-09-14 at 16.54.57.png

Screen Shot 2020-09-14 at 16.56.19.png
Screen Shot 2020-09-14 at 16.53.50.png


  • EFI.zip
    2.1 MB · Views: 5
  • DSDT.aml.zip
    23.6 KB · Views: 4
  • USBMap.kext.zip
    2.8 KB · Views: 5
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.