Radeon reboot OpenCore

xavierbaez

New member
AMD OS X Member
Joined
Feb 13, 2022
Messages
29
Has anybody experienced reboots with Radeon graphic cards?

Tried two cards
  • Radeon 6909 XT
  • Radeon RX 580
Three different operating systems
  • Big Sur
  • Monterey
  • Ventura
Big Sur seems to be the most stable one.
The screen goes blank with no apparent errors
The fans stop spinning on the graphic cards

Then sometimes it boots into macOS X
Majority of times it reboots

This is the last image I see.
I have OpenCore DEBUG
 

Attachments

  • IMG_5322.jpeg
    IMG_5322.jpeg
    681.6 KB · Views: 4

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,201
Post a copy of the EFI you are using, and let us know which GPU you are using with the EFI.

The RX580 should boot macOS without any 'fixes or patches'.

The RX6900 XT will require agdpmod=pikera boot argument added to the config.plist otherwise you will get a black screen when you should see the macOS login screen.

Assumption: You are using the Asus ROG X570 motherboard and Ryzen 7 5950X CPU in your signature with these two dGPU's.
 

xavierbaez

New member
AMD OS X Member
Joined
Feb 13, 2022
Messages
29
Yes I posted me my EFI in the other post but it was deleted.

Where’s the best website to upload the EFI folders?

I did add
agdpmod=pikera

Sometimes even after booting it reboots, for example I was disabling BetterSnapTool and it rebooted.

Do you know how to boot without 3D acceleration just to see if that’s the root cause?
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,201
Boot in Safe Mode using -x boot argument. That will boot the system in VESA mode, i.e. no graphics acceleration. It also limits other aspects when running macOS and is just meant for troubleshooting issues.

Can you confirm which release of macOS Monterey you are running and which version of OpenCore you are using.

You need to compress/zip your EFI folder and post a copy here, not on some other site. Just make sure to remove the Apple and Microsoft folders (if they are present) before you zip the EFI folder, as they are not needed for troubleshooting this issue.
 
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.