CMOS reset required to boot after wake from sleep, help!

Pixfix

New member
AMD OS X Member
Joined
May 4, 2020
Messages
12
Any ideas on why waking from sleep crashes my computer and requires a CMOS reset to boot?

I’ve had intermittent sleep issues ever since I first started in OC 6 era, where often waking from sleep would crash the computer (only in macOS) and require a CMOS reset to boot. This happened so often that I installed a switch to make shorting the pins easier. I eventually figured out that it wouldn’t crash as often if I woke the computer by pressing the power button on the case instead of tapping the keyboard/ mouse. I’ve tried to do USB mapping with several methods, but none seem to help (or I’ve not done it correctly).

After upgrading my monitor and using a different usb hub / switch, I suddenly stopped having these crashes for several months on OC 8.3. Thinking that the new hardware had solved the issue, I decided to upgrade my 3900x to a 5950x and get the machine ready for Ventura/ Sonoma. As soon as I updated my BIOS (and updated all OC-safe bios settings) the crashes came back. I decided to move forward with the CPU and OC update, thinking maybe the newer OC 9.3 would work better with the newer BIOS, but no luck.

I’ve lurked here enough to know that often a single setting can make all the difference (hopefully!). Though my best guess is that I need something more robust than the generic SSDT-EC-USBX-DESKTOP.aml, but I am really struggling to understand the SSDT process. I would be so grateful for any suggestions. Specs and EFI below. Thank you!

Hardware
  • ASUS Pro WS X570-Ace
  • Ryzen 5950x
  • Powercolor Red Dragon 6800
  • Corsair Vengeance LPX 3200 64GB (16x4)
  • EVGA Supernova 850W Titanium
  • WD SN850 1TB (Monterey)
  • WD SN770 2TB (Windows 11)
  • Intel 660P 2TB in Angelbird PCIE Adapter
  • Micron 8TB sata ssd
  • Laird BT85x USB Bluetooth module - Cypress CYW20704 A2 chipset (only use occasionally)
  • FiiO K3 USB DAC
  • Cable Matters USB 2.0 Switch hub (for sharing kb & mouse)
OC 9.3 Built manually from Dortania Guide (used OCAT to update from 8.3->9.3)
Bios version 2.20.1271
Monterey 12.6.8

BIOS Settings - Disabled
  • Realtek LAN Controller
  • USB power delivery in Soft Off state (S5)
  • Serial Port
  • Legacy USB Support
  • Launch CSM
  • Fast Boot
  • Resize BAR Support
  • Precision Boost Overdrive
  • Core Performance Boost (enabled when needed)
  • ErP Ready
  • Power on by PCI-E
  • Power on by RTC
Bios Settings - Enabled
  • Intel LAN Controller
  • Above 4G Decoding
  • OS Type - Windows UEFI mode
  • XHCI Hand-off
 
Last edited:
Solution
@Pixfix,

Okay so I had a further look at your build and found a few things. Firstly is I see you have both AppleALC & AppleALCU enabled. You cannot enable both sadly because that will cause conflicts and crashing. I understand you also have a Fiio USB DAC attached - if you use just the AppleALC that will work along with your onboard Realtek card.
Aside from that your setup was missing a bunch of ACPI settings like PLUG & SBUS-MCHC. In my experience the B550/B570 boards all require these pretty much. So I have added those in for you. I've also enabled the XHC rename ACPIs that I found were needed on my B550. I've enabled it so that you can test and check if it needs improving.
Lastly I have enabled ReleaseUSBOwnership. I found...

Pixfix

New member
AMD OS X Member
Joined
May 4, 2020
Messages
12
Wow! Thank you so much for your help! I will try your tweaks and report back.

PSU is possible, but seems unlikely. This issue started when I was still using a 3900x. I usually leave core boost and pbo off, and never have issues gaming or rendering in windows. Does the power spike over 500w+ immediately when waking from sleep (only time it crashes)? Additionally, I used to have this machine plugged into a UPS that could measure total power including display, and rarely went over 400W in normal usage, usually around 200w.

thanks again!!!

-- update --
I added your .aml files and the ReleaseUSBOwnership setting in config. Putting my system to sleep caused a sort of limbo mode. The screen would turn off but it wouldn't go completely to sleep, but also wouldn't wake up without a reboot. Removed the CPUR (looks like thats not recommended for x570), and so far so good! Manual sleep/ wake is working. Crossing my fingers it wakes up in the morning :)

Middleman, you mentioned in your first post that I should try separate EC and USBX files, but you had them disabled in my config. I tried enabling them and disabling the combined SSDT-EC-USBX-DESKTOP, but the system wouldn't boot. Hopefully this doesn't matter, just curious how to set up the split files incase I need to try that next.
 
Last edited:

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,201
You need to create the custom SSDT-EC.aml and SSDT-USBX.aml, plus any others you need using Corpnewt's SSDTTime script and your system DSDT.aml.

 
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.