ASRock X570 ITX/TB3 + Ryzen 9 5900X + RX 5500 XT → iMacPro1,1

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
OpenCore ver 0.7.4 · BigSur 11.6

Update, Oct 5th 2021: GitHub repo has updated hardware list and current EFI.



Original post, Dec 5th, 2020:

Current hardware, pretty much upgrade to my earlier build using R5 3600.


This all works great and silent with this AIO, with max CPU temps around 80°C when all 12 cores are fully loaded.


WiFi / Bt​


The combo below offers natively supported WiFi 5 / Bluetooth 4.


Combined with this riser cable, the card/adapter combo from above can be moved outside the motherboard I/O shroud, instead of existing Intel AX200 card.

- Mini PCIe riser with adapter for M.2 Key A/E

BIOS​


Version 2.71

  • Fast Boot: Disabled
  • CSM: Disabled
  • Above 4G Decoding: Enabled
  • PCIe speed: Gen 3 (do not leave it on Auto)
  • XMP Profile set and running.

What’s working​


Pretty much everything.

  • NVMe SSD recognised properly.
  • WiFi, Bluetooth, Ethernet
  • All USB ports properly mapped. Steck case does not have any ports thus internal USB header is not connected.
  • Radeon GPU, natively supported.
  • All media services (Plex, Netflix in Safari, iTunes, Apple TV+ etc). All are fully hardware-accelerated.
  • 4K HDMI with HDR, Dolby.
  • Watch unlock, Handoff, iMessage, iCloud, Keychain, Xcode etc.
  • System Integrity Protection (SIP) fully enabled.

What’s not working​


  • Sidecar
  • Sleep / wake
  • Thunderbolt 3
 
Last edited:

sffjawsh

New member
Joined
Oct 22, 2020
Messages
2
@atanvarno Congrats on the great build! Question about your WiFi/BT setup. What's the use of the mini PCIe adapter card? Seems to me that the combo of Broadcom BCM94360CD and the M.2 key A/E riser cable should suffice since the BCM94360CD would slot in directly at other end of the same cable. Curious to know. Thanks!
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
@atanvarno Congrats on the great build! Question about your WiFi/BT setup. What's the use of the mini PCIe adapter card? Seems to me that the combo of Broadcom BCM94360CD and the M.2 key A/E riser cable should suffice since the BCM94360CD would slot in directly at other end of the same cable. Curious to know. Thanks!
That combo is too tall to fit inside the I/O shroud. Thus I need to bring it outside of that.

Second reason (even if it fit) is that 94360CD card has 4 antenna connectors which also need to be led somewhere outside the chassis. Currently the antennas are glued to the back of the case. Ideally I would have some 3D-printed bracket for 4 (RP-)SMA connectors but I know nothing about 3D printing, so 🤷🏻‍♂️
 

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
That combo is too tall to fit inside the I/O shroud. Thus I need to bring it outside of that.

Second reason (even if it fit) is that 94360CD card has 4 antenna connectors which also need to be led somewhere outside the chassis. Currently the antennas are glued to the back of the case. Ideally I would have some 3D-printed bracket for 4 (RP-)SMA connectors but I know nothing about 3D printing, so 🤷🏻‍♂️
The BCM94360ng card works well and will fit in the IO. I have one on my X470 build. That frees up the PCI lanes for graphics or other add ons.
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
Yeah, but I already had these bought like a year ago, from AliExpress. :) I discovered NG few months after ordering. It was a shame to throw these away.
 
Last edited:

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
Yeah, but I already had these bought like a year ago, from AliExpress. :) I discovered NG few months after ordering. It's a shame to throw it away.
Yes, the ng is a little pricey as well but its better then the 4352, 4322 etc..
 

Jayz-enrico

New member
Joined
Dec 6, 2020
Messages
20
Hi ...first congratulations for your build. How do you did that? I tryed everything with my Ryzen 9 5900x but the Videos are running to fast in youtube and there is no Audio. Mac os is running but with many issues. No Audio and videos are running to fast. Do u have this issue too?
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
701
Since Zen 3 reports as 19h instead of 17h, OC before 0.6.4 does not correctly detect and handle those CPUs which leads to Audio and other issues.
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
So last evening, I replaced the XPG fans on the Levante 240 AIO with Noctua NF-A12x25, plus also switched air direction. From exhausting air through the radiator and out of the case I went to intake cold air through the radiator and then push that down through the case and exhausting at the bottom.

These two changes lowered the CPU temps from 83-85ºC at highest down to about 66-68ºC, while chipset and GPU were pretty much not impacted, maybe few degrees.

Darn awesome. And these Noctua fans are utterly silent. So I have 3 of them now, two on the radiator and one at the bottom of the case and it's darn glorious.
 

hj00nn

New member
Joined
Dec 30, 2020
Messages
1
I have some identical build as yours.

  • AMD Ryzen 9 5600X CPU
  • Thermalright AXP-90 Full back CPU Cooler
  • ASRock X570 Phantom Gaming-ITX/TB3 motherboard (BIOS 2.8.0)
  • HIS Radeon VII GPU
  • ESSENCORE DDR4 32GB PC4-25600 CL16 KLEVV BOLT X (16GB x2)
  • Corsair SF750 Platinum SFX PSU
  • Noctua NF-A12x25 case fan
  • Samsung 970 PRO 512GB NVMe SSD
  • KLEVV NEO N610 1TB TLC 2.5" SATA SSD
  • formd T1 v1.1

with help from this repo I was able to sleep : (https://github.com/aluveitie/RyzenMacPro/tree/asrock-x570-itx)
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
I updated the build and added SMBus support, tweaked few less important properties.
I was hoping to enable TB3 as well, but it both available versions od TbtForcePower.efi don't work with this build.
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
Connecting the SMBus always broke sleep for me.
Sleep never worked for me, so 🤷🏻‍♂️. Not concerning that much, this computer is almost always doing something.

TB3 remains elusive. I have TB3 working rather well for external disks on ASRock Z490, where this same controller is present. TbtForcePower.efi was key ingredient in making it work and I'm bummed that it fails to even start in this setup. Halts on critical error. There seem to be great SSDT available at HackinDROM for this board and I am really eager to try it but I doubt it will do anything without forcepower efi driver.
 

atanvarno

Donator
Donator
Joined
May 2, 2020
Messages
98
I recently moved the small 5500 XT card into another build and brought back the RX 570. Still chugging along just fine and is able to run what I need perfectly. Moved entire build from Nouvolo Steck case into Sliger S620 which is an amazing chassis.

The link from first post still works and GitHub repo is maintained. Currently on 0.7.4 and with all patches updated.
 
Top Bottom