Win10 Dual Boot - Desktop clock wont stay correct

jthunternz

Donator
Donator
AMD OS X Member
Joined
Sep 9, 2020
Messages
20
Hi,

Since having a dual boot system with Catalina and Win10. The desktop clock in my Win10 installation wont stay the same between reboots. I.E it says its 7:09pm but actually its 8:09am.
I haven't changed any windows settings etc. Wonder if anyone can help with this?
 

Moozuki

Active member
AMD OS X Member
Joined
May 3, 2020
Messages
205
Copied from another web site :

It's quite simple really. All you need to do is set Windows to use UTC instead of GMT. To do this - we need to perform a simple registry edit. Go perform this - hold down the 'Windows' button, and at the same time press R (Win + R) this will bring up a new window titled 'RUN'

In this window type the command 'regedit'. UAC will popup asking for admin permission. Click accept and the registry editor will open. Now that were in regedit, navigate to...

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
Left click on 'TimeZoneInformation' and on the left it will display all the current values attributed to this registry key. On the left right click anywhere and choose 'Create new D-WORD'. You will now see a new entry at the bottom of the list.

Right click on this new entry and choose 'Modify'. Rename the key 'RealTimeIsUniversal' and change it's value to '1'. Click save, and now the entry should say 'RealTimeIsUniversal - 0x0000001' If it looks like that - then you're all done!

Reboot, and sync the windows clock - now your time settings will be universal (no pun intended :p ).
 
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.