High Sierra smcamdprocessor.kext () - Invalid Parameter Error

haris

New member
AMD OS X Member
Joined
Dec 26, 2022
Messages
1
i can't understand what's wrong.
I tried to instal it with OpenCore but whenever i try to install High Sierra it's gave me this error.




and there is my Efi and config.pls Files:
(When i tried different EFI it took me to the setup screen but, it stuck in blank grey screen.
Can you help me pls?

My Pc Specs:
Ryzen 5 1600AF
A320M-K
RX 570
16 GB DDR4 3200MHZ
 

Attachments

  • EFI.zip
    2.7 MB · Views: 1
  • config (2).plist
    41.9 KB · Views: 0

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,445
You are using a version of OpenCore from December 2020. So I assume this is not your own EFI. Whose EFI are you using? How do you know it is correct for your setup?

The OC setup as well as being old, is not that well formatted.

Here is an OpenCore EFI folder that uses OC 0.8.7 and the latest release of the AMD Kernel Patches. It has been setup to work with your 6-Core CPU, following the most recent Dortania Ryzen guide.

Try it in place of your current EFI folder. See if this gets you to the macOS High Sierra installation wizard.

Make sure you use the ResetNvramEntry from the OC boot screen before you try booting in to the macOS installer. This entry will be hidden, so you need to press the spacebar to display the hidden icons when you arrive on the OC boot screen. It should reset/clean the NVRAM entries and automatically reboot the system.

If you get stuck at any point post a photo of the verbose text.
 

Attachments

  • EFI.zip
    11 MB · Views: 1
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.