Got a kernel panic trying to install macOS (Lenovo IdeaPad Ryzen 4300u)

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
Trying to install macOS on laptop Lenovo IdeaPad 3 15ARE05

Specs:
AMD Ryzen 3 4300U
AMD Radeon Graphics Vega
NVME SSD 500GB

Created EFI folder by following Dortania's guide, and still getting a kernel panic, that says about something called "invalid frame pointer"

Can someone please help me fix this issue?
 

Attachments

  • photo_2023-06-07_18-58-17.jpg
    photo_2023-06-07_18-58-17.jpg
    231.4 KB · Views: 18

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,200
Post a copy of your EFI so we can see wha you are using to run macOS on this AMD Laptop.

The screen image you posted doesn't tell us much and without seeing your EFI we have nothing to go on or correct.
 

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
Post a copy of your EFI so we can see wha you are using to run macOS on this AMD Laptop.

The screen image you posted doesn't tell us much and without seeing your EFI we have nothing to go on or correct.
So, i changed a couple quirks following General troubleshooting guide about invalid frame pointer
This one:

And got another kernel panic, ever scarier. I hope it can be fixed

Here is my EFI folder. Many thanks in advance for helping!
 

Attachments

  • panic.jpg
    panic.jpg
    233.2 KB · Views: 17
  • EFI.zip
    1.8 MB · Views: 8

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,200
Try this OC EFI in place of your current one, see if this works any better.
 

Attachments

  • EFI.zip
    28.2 MB · Views: 7

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
Try this OC EFI in place of your current one, see if this works any better.
Now i'm getting this log (pic 1)
Since i followed Dortania's USB creation guide, my flash drive structire looks like this (pic 2)
So basically, my usb contains macOS recovery dmg, and EFI folder in same partition.

Should i remake my USB using macOS virtual machine, Mac App Store OS image, and createinstallmedia Terminal utillity?

Edit: Got the same result by making another one USB using macOS VM & Terminal utillity
 

Attachments

  • error.jpg
    error.jpg
    146 KB · Views: 13
  • usb.png
    usb.png
    6.5 KB · Views: 11
Last edited:

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,200
OK, that means the EFI setup went backwards, to kernel panic at an earlier point.

I have changed the SSDT-EC-USBX-AMD.aml table for the one you were using previously, as that passed this point in the boot process.

Try with this EFI-2.zip and see what occurs.
 

Attachments

  • EFI-2.zip
    28.2 MB · Views: 6

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
OK, that means the EFI setup went backwards, to kernel panic at an earlier point.

I have changed the SSDT-EC-USBX-AMD.aml table for the one you were using previously, as that passed this point in the boot process.

Try with this EFI-2.zip and see what occurs.
I tried the new EFI folder, and got exactly the same result. Tried on both of my USB, w/ full installer and recovery only.
One thing to clarify, i posted this topic in 11.0 Big Sur thread, but what i'm trying to install is 12.0 Monterey. If that is important, then i'm very sorry for posting it in wrong thread, i hope we can work this out
 

Attachments

  • full installer.jpg
    full installer.jpg
    145.6 KB · Views: 8
  • recovery only.jpg
    recovery only.jpg
    168.6 KB · Views: 13

shuhung

New member
AMD OS X Member
Joined
Jul 13, 2020
Messages
15
First png seems to be caused by NootedRed.kext, make sure CSM is disabled on BIOS, and not used for OS installation.

Recently, NootedRed.kext need to be disabled for macOS fresh installation / system upgrade, re-enable it after installation or system update.
 

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
First png seems to be caused by NootedRed.kext, make sure CSM is disabled on BIOS, and not used for OS installation.

Recently, NootedRed.kext need to be disabled for macOS fresh installation / system upgrade, re-enable it after installation or system update.
Tried to boot with disabled NootedRed.kext and got the same result. Also there is no CSM option in my BIOS, so i can't disable it
 

shuhung

New member
AMD OS X Member
Joined
Jul 13, 2020
Messages
15
Try my current EFI for 2200g /5600g, pls disable nootedred.kext for installation.
 

Attachments

  • 5600g:2200g EFI.zip
    4.2 MB · Views: 8

shuhung

New member
AMD OS X Member
Joined
Jul 13, 2020
Messages
15
Try reset NVram, press spacebar from opencre boot menu, select Clear NVRAM reboot.
 
Last edited:

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
Try reset NVram, press spacebar from opencre boot menu, select Clear NVRAM reboot.
I already did this once, and Bios and the boot menu stopped opening for me, so I had to backflash the bios to make it work again.

Edit: Well, i did that, still getting kernel panic, and now BIOS and Boot Menu didn't show up, instead OpenCore menu appears
 
Last edited:

kaus08

New member
AMD OS X Member
Joined
Jun 8, 2023
Messages
1
Trying to install macOS on laptop Lenovo IdeaPad 3 15ARE05

Specs:
AMD Ryzen 3 4300U
AMD Radeon Graphics Vega
NVME SSD 500GB

Created EFI folder by following Dortania's guide, and still getting a kernel panic, that says about something called "invalid frame pointer"

Can someone please help me fix this issue?
Also having the same error, Ideapad 3 Ryzen 7 5700U / Vega 8. I'll be following here but if I find any fix Ill let you know.
 

shuhung

New member
AMD OS X Member
Joined
Jul 13, 2020
Messages
15
I already did this once, and Bios and the boot menu stopped opening for me, so I had to backflash the bios to make it work again.

Edit: Well, i did that, still getting kernel panic, and now BIOS and Boot Menu didn't show up, instead OpenCore menu appears

I double checked with attached EFI (5600g and 2200g), it pass macOSs fresh install and work fine after installation, Big Sur, Monterey OK, only Ventura has cold boot issue, need boot from Monterey first then reboot to Ventura ok.

Seems to be Laptop ACPI tables are more complex than Desktop.

For fresh installation, less is better

1, use CPUR.aml + PLUG.aml + EC-USBX.aml

2, kexts use LILU + VirtualSMC

3, UEFI Quirks set releaseUsbOwnership to yes

Try attached config, also upload your current config PLS.
 

Attachments

  • Config install.plist
    41.5 KB · Views: 2

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
I double checked with attached EFI (5600g and 2200g), it pass macOSs fresh install and work fine after installation, Big Sur, Monterey OK, only Ventura has cold boot issue, need boot from Monterey first then reboot to Ventura ok.

Seems to be Laptop ACPI tables are more complex than Desktop.

For fresh installation, less is better

1, use CPUR.aml + PLUG.aml + EC-USBX.aml

2, kexts use LILU + VirtualSMC

3, UEFI Quirks set releaseUsbOwnership to yes

Try attached config, also upload your current config PLS.
Tried this config with your EFI folder - got the same kernel panic. My original EFI attached to post #3 in this thread. Also i tried EFI's by Edhawk, they also attached to his messages
 

shuhung

New member
AMD OS X Member
Joined
Jul 13, 2020
Messages
15
I edited your EFI and tested with my 5600g, it work with some kexts disabled, work fine, USB installer passed with nootedred disabled, issue seems to be cause by ACPI code, different from desktop mother board, I don't have AMD laptop, can not dump ACPI table for test.
Anyway, do one more test with attached EFI.
 

Attachments

  • EFI edited.zip
    1.8 MB · Views: 4

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
I edited your EFI and tested with my 5600g, it work with some kexts disabled, work fine, USB installer passed with nootedred disabled, issue seems to be cause by ACPI code, different from desktop mother board, I don't have AMD laptop, can not dump ACPI table for test.
Anyway, do one more test with attached EFI.
Thank you for your responses. Unfortunately, i got the same kernel panic as usual like in #11 post (com.apple.driver.AppleACPIPlatform(6,1)

Edit: I just created a dump, using SSDTTime and got .aml file. Maybe it can help somehow
 

Attachments

  • DSDT.zip
    16.1 KB · Views: 3
Last edited:

Middleman

Active member
AMD OS X Member
Joined
Jan 29, 2021
Messages
723
For those interested, there is a working OC 0.9.2 Big Sur EFI build for Lenovo Ryzen Yoga 16S 7 5800H using NootedRed found here > https://github.com/zabdottler/Lenovo-Yoga-16S-hackintosh

To make it works, just make sure the settings for the Ryzen under Kernel > Patches match up with the number of cores you have in your system.
 

imwrkacc

New member
AMD OS X Member
Joined
Jun 7, 2023
Messages
18
For those interested, there is a working OC 0.9.2 Big Sur EFI build for Lenovo Ryzen Yoga 16S 7 5800H using NootedRed found here > https://github.com/zabdottler/Lenovo-Yoga-16S-hackintosh

To make it works, just make sure the settings for the Ryzen under Kernel > Patches match up with the number of cores you have in your system.
Tried this EFI, and there is no Install macOS boot option, even after hitting space button.
 
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.