Color Banding Issues / Sapphire RX 580 8GB

aetherium

New member
AMD OS X Member
Joined
Aug 18, 2023
Messages
2
My full specs:
Motherboard: GIGABYTE B450-M DS3H
CPU: AMD Ryzen 5 2600X
GPU: Sapphire RX 580 8GB
RAM: 16GBx1 3000mHz
OS version: macOS Ventura 13.5.1
SMBIOS: MacPro7,1 (Mac Pro 2019)
---------------------------------
Good day, recently I have encountered huge problems with color banding on my hackintosh. For example, I simply can't use any kind of blur or gradient in Photoshop or any other software, because transition between color is very sharp, and my eyes are literally bleeding because of this. Is there any way to fix this issue? I have heard something about "Spoofing KBL as SKL" and spoofing gpu, but I have no idea how to do this. I will appreciate any kind of help, thanks
 

Attachments

  • 2023-08-18_21-34.jpg
    2023-08-18_21-34.jpg
    102.7 KB · Views: 11

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,461
Using the GPU spoof or KBL as SKL won't help you.
The first because your RX580 is natively supported in macOS.
The second because you have an AMD system, lacking an Integrated Intel GPU that the Kaby Lake (KBL) to Skylake (SKL) spoof is meant for.

Can I ask what the image attached above was meant to show, as it doesn't explain or help us understand the issue you are facing.

Are you using AMDFriend? If not it may be worth a read and installing the kext to see if it helps.

Source:
Guide:
 

aetherium

New member
AMD OS X Member
Joined
Aug 18, 2023
Messages
2
Using the GPU spoof or KBL as SKL won't help you.
The first because your RX580 is natively supported in macOS.
The second because you have an AMD system, lacking an Integrated Intel GPU that the Kaby Lake (KBL) to Skylake (SKL) spoof is meant for.

Can I ask what the image attached above was meant to show, as it doesn't explain or help us understand the issue you are facing.

Are you using AMDFriend? If not it may be worth a read and installing the kext to see if it helps.

Source:
Guide:
Thank you for your reply. If you take a closer look to the screenshot that I had attached, you will see these sharp color edges, that my system is rendering. I wish this issue was my display's fault, but, unfortunately, that's how my gpu works in this system.
Im sorry, but there is only AMDFriend binary file at these github repo, not .kext files.
 

Middleman

Active member
AMD OS X Member
Joined
Jan 29, 2021
Messages
723
Afaik there really shouldn't be any colour banding issues with the RX580 series since it is a supported GPU in macOS.

However it could be something to do with your configuration? Two things you could do though, first is check if EnableVectorAcceleration
is enabled under UEFI > Quirks and see if that helps. It is designed to improve the graphical performance of the GPU.

Second, is you may need to perhaps enable Force RGB Mode using this guide, to help reduce the colour banding. Hackintool will be required to create
a patch-EDID kext that you need to add into your EFI/OC/Kexts folder. >
 
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.