ASUS ROG STRIX GAMING WIFI B650E-F | RYZEN 7 7700X | OC 0.9.9 | RX 6600XT | TP-Link TX401 |Sonoma 14.4

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
IMG_1831.jpegIMG_1830.jpeg

ASUS ROG Strix Gaming WIFI B650E-F
Ryzen 7 7700X | RX 6600XT | 64GB Corsair Vengeance EXPO | Fractal North Mid Tower ATX

Brief History
After building Intel systems for Mac use for many years with my last system being a Z690 i7-12700KF, I decided to move back to AMD which I built from the old Athlon 64 / Phenom ii days.. :geek:


Build
After using Gigabyte boards for many years, I decided to go with ASUS even with their bad reputation at the moment.. BAD luck was on its way to me as my first board was DOA.. great start, but after receiving my replacement everything kicked into gear.

I updated the BIOS to verson 1616 and defaulted the BIOS the only settings I changed was to disable the onboard WIFI, Bluetooth, TPM, CPU PPT limit to 85 and Thermal Limit to 85.

I Created my EFI folder from parts of @CaseySJ @amdeez @Edhawk @Shaneee & Dortania Work.. Many Thanks for your hardwork (y) and also to everyone in the Ryzen 7000 testing thread.. must of spent weeks reading it all.

As I had Monterey 12.6.6 on my Z690 system as I didn't like Ventura (well when I tried it at version 13.2) I decided to keep Monterey on the new system for now.. install was just a easy as an Intel system and completed without problem, only problem I did get when I logged in for the first time was no Audio... this board has USB Audio.. so used the excellent USBMap to map my usb ports and the audio came up.. Happy Days :)


With the CPU at stock settings in BIOS
CPU Score_Before Change.png

With the CPU PPT Limit set to 85 & Thermal limit set to 85
CPU Score at 85w limit.png


My RX6600XT with @Shaneee fix and Powertables added as well... I'm getting
RX6600XT Metal Score.pngRX6600XT OpenCL Score.png

TP-Link TX401 10G PCIE Card
IMG_2249.JPG

What Works
Everything that I used on my Intel system works with my Ryzen system
Fenvi FV-T919 Card removed as no longer works in Sonoma without patches
Intel NIC disabled in BIOS due to crashes, Using a Realtek PCI NIC card instead

10G Networking with TP-Link TX401 Card
iCloud

iMessage
 
Last edited:

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
Opencore Updates
Please make sure you...
add your own serial / model details
change the processor core count patches to match yours as the EFI is configured for a 7700X
add your own USB patches

add intel kext if you wish to use the onboard NIC


4th June 2023 - OC 0.9.2
Monterey & Ventura patches active
no USB Port mappings included
1 of the 5 MmioWhitelist activated

13th June 2023 - OC 0.9.3
Monterey & Ventura patches active
no USB Port mappings included
4 of the 5 MmioWhitelist activate

28th January 2024 - OC 0.9.7
Sonoma patches active
no USB Port mappings included
removed intel nic kext as I was getting hangs and crashes (Intel nic is disabled in BIOS)
1 of the 5 MmioWhitelist activated
9th February 2024 - OC 0.9.8
Sonoma patches active
added BIOS Fix aml to ACPI folder to allow boot with BIOS 1807+ (Thanks to Lorys89)
no USB Port mappings included
added sbvmm to boot-args
removed AMDRyzenCPUPowerManagement & SMCProcessorAMD from kexts folder
no intel nic kext included
1 of the 5 MmioWhitelist activated
17th March 2024 - OC 0.9.9
as per OC 0.9.8 update with the added updates...
10G network patches applied
changed secure boot to MacPro7,1
 

Attachments

  • OC 0.9.2_EFI.zip
    4.7 MB · Views: 6
  • OC_0.9.3_EFI.zip
    4.7 MB · Views: 29
  • OC 0.9.7_EFI.zip
    4.7 MB · Views: 14
  • OC 0.9.8_EFI.zip
    4.3 MB · Views: 26
  • OC 0.9.9_EFI.zip
    4.3 MB · Views: 78
Last edited:

dekuyt

New member
AMD OS X Member
Joined
May 18, 2022
Messages
21
View attachment 10829View attachment 10830

ASUS ROG Strix Gaming WIFI B650E-F
Ryzen 7 7700X | RX 6600XT | 64GB Corsair Vengeance EXPO | Fenvi FV-T919 | Fractal North Mid Tower ATX

Brief History
After building Intel systems for Mac use for many years with my last system being a Z690 i7-12700KF, I decided to move back to AMD which I built from the old Athlon 64 / Phenom ii days.. :geek:


Build
After using Gigabyte boards for many years, I decided to go with ASUS even with their bad reputation at the moment.. BAD luck was on its way to me as my first board was DOA.. great start, but after receiving my replacement everything kicked into gear.

I updated the BIOS to verson 1616 and defaulted the BIOS the only settings I changed was to disable the onboard WIFI, Bluetooth, TPM, CPU PPT limit to 85 and Thermal Limit to 85.

I Created my EFI folder from parts of @CaseySJ @amdeez @Edhawk @Shaneee & Dortania Work.. Many Thanks for your hardwork (y) and also to everyone in the Ryzen 7000 testing thread.. must of spent weeks reading it all.

As I had Monterey 12.6.6 on my Z690 system as I didn't like Ventura (well when I tried it at version 13.2) I decided to keep Monterey on the new system for now.. install was just a easy as an Intel system and completed without problem, only problem I did get when I logged in for the first time was no Audio... this board has USB Audio.. so used the excellent USBMap to map my usb ports and the audio came up.. Happy Days :)


With the CPU at stock settings in BIOS
View attachment 10839

With the CPU PPT Limit set to 85 & Thermal limit set to 85
View attachment 10840


My RX6600XT with @Shaneee fix and Powertables added as well... I'm getting
View attachment 10842View attachment 10845



What Works
Everything that I used on my Intel system works with my Ryzen system
Bluetooth (use watch to unlock & enter password)
WiFi
Ethernet
iCloud

iMessage
Hi. I'll Try your EFI for my B650E-E
 

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
I have updated opencore to 0.9.7
I upgraded to Sonoma, so I removed my wifi card - didnt really use it anyway
Been getting werid hangs and slow downs while using the intel nic since Ventura, tried all sorts.. none of them seemed to work to got a cheap realtek pci card and all working great with the RealtekRTL8111.kext
 

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
I have updated opencore to 0.9.8
Please find the changes and a copy in post 2
 

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
Updated opencore to 0.9.9
Please find the changes and a copy in post 2
 

MaxSkye

New member
AMD OS X Member
Joined
Mar 17, 2024
Messages
5
I have updated opencore to 0.9.8
Please find the changes and a copy in post 2
Hello! What does BIOS fix actually do? Without it my pcie ax200 doesn't work. It is very strange. My motherboard - asrock x670e pg
 

leesurone

Donator
Donator
AMD OS X Member
Joined
May 6, 2020
Messages
359
Hello! What does BIOS fix actually do? Without it my pcie ax200 doesn't work. It is very strange. My motherboard - asrock x670e pg
The AM5-BIOS-Fix by @Lorys89 that @andyxm715 is using does a number of things. One part of it allows the system to boot if you have updated the bios to the point it enables the Ryzen 8000 processors class.
 
Last edited:

andyxm715

New member
AMD OS X Member
Joined
May 29, 2023
Messages
11
Hello! What does BIOS fix actually do? Without it my pcie ax200 doesn't work. It is very strange. My motherboard - asrock x670e pg
I was on version 1654, I only update the BIOS if I really need to.. sadly for my board.. version 2214 included a security fix which I wanted to update too.. but the version before 1807 included an update for the latest 8000 series processors which needs the BIOS patch for... otherwise I would of stayed on 1654.
 

MaxSkye

New member
AMD OS X Member
Joined
Mar 17, 2024
Messages
5
The AM5-BIOS-Fix fby @Lorys89 that @andyxm715 is using does a number of things. One part of it allows the system to boot if you have updated the bios to the point it enables the Ryzen 8000 processors class.
So. My motherboard (Asrock X670E PG Lightning) does support the 8000 series of processors, but there is not a single mention in the changelogs. It seems to be supported with the first version of the BIOS. Now I have the latest version 2.10. It starts without Bios fix, but the PCIE Intel AX200 does not work even with the correct kext. Bios fix somehow fixes this and I wanted to figure out exactly how. And where I can get the source code for this fix.
 
Last edited:

leesurone

Donator
Donator
AMD OS X Member
Joined
May 6, 2020
Messages
359
So. My motherboard (Asrock X670E PG Lightning) does support the 8000 series of processors, but there is not a single mention in the changelogs. It seems to be supported with the first version of the BIOS. Now I have the latest version 2.10. It starts without Bios fix, but the PCIE Intel AX200 does not work even with the correct kext. Bios fix somehow fixes this and I wanted to figure out exactly how. And where I can get the source code for this fix.
You can open the SSDT with MaciASL and poke around. As mentioned @Lorys89 is the creator of the SSDT and participates in this forum occasionally

 

dekuyt

New member
AMD OS X Member
Joined
May 18, 2022
Messages
21
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.