[Catalina 10.15.7] AMD 3950x + Gigabyte Aorus x570 pro wifi (bios F12) + Sapphire rx 5500xt 4GB

igerry

New member
Joined
Jun 25, 2020
Messages
16
29 Sep Update 3: update to 10.15.7 (from 10.15.6), works as usual.
15 Aug Update 2: update to 10.15.6 (19G2021), works as usual.
17 Jul Update 1: update to 10.15.6 (from 10.15.5), works as usual.

Screen Shot 2020-07-17 at 7.11.45 pm.png

CPU: Ryzen 3950x
GPU: Sapphire Radeon RX 5500XT 4GB
RAM: 32GB of Corsair LPX 3200MHz
Motherboard: Gigabyte Aorus Pro X570 Wifi (have to use bios F11 or F12 to enter recovery. After installation, F21 works fine.)
Audio: ALC1220VB (on Motherboard)
Ethernet: 1G (on Motherboard)
WiFi/BT Card: Broadcom BCM94360CS2 (remove the Intel AX200 and install at the same mini PCIE port)
SMBIOS: iMacPro1,1

Everything works except 1. sleep & 2. mic.
Pretty impressive benchmark in Cinebench r20 without overclocking.

Screen Shot 2020-07-18 at 10.18.40 am.png

For this build I used the OpenCore Desktop Guide.

OpenCore: 0.5.9
Kexts: Lilu.kext, WhateverGreen.kext, VirtualSMC.kext, SmallTreeIntel82576.kext, AppleALC.kext
Kexts Optional: SMCAMDProcessor.kext, AMDRyzenCPUPowerManagement.kext (I find they are not 100% stable and may cause panic sometime, so I don't use them for long term use)
ACPIs: SSDT-EC-USBX-DESKTOP.aml, SSDT-NVME.aml, SSDT-XHC.aml
Drivers: HfsPlus.efi, OpenCanopy.efi, OpenRuntime.efi
Please use your own SMBIOS generated serial in the config.plist.
 

Attachments

  • EFI.zip
    2.1 MB · Views: 40
Last edited:

eliob

New member
Joined
Jul 3, 2020
Messages
8
Update from 10.15.5 today, works as usual.

View attachment 805

CPU: Ryzen 3950x
GPU: Sapphire Radeon RX 5500XT 4GB
RAM: 32GB of Corsair LPX 3200MHz
Motherboard: Gigabyte Aorus Pro X570 Wifi (have to use bios F11. otherwise can not go into the recovery)
Audio: ALC1220VB (on Motherboard)
Ethernet: 1G (on Motherboard)
WiFi/BT Card: Broadcom BCM94360CS2 (remove the Intel AX200 and install at the same mini PCIE port)
SMBIOS: iMacPro1,1

Everything works except 1. sleep & 2. mic.
For this build I used the OpenCore Desktop Guide.
can you share your refi please?
 

tkl2001

New member
Joined
Jul 24, 2020
Messages
18
Hi, your setup is nearly the same as mine. Any luck getting sleep to work?
 

igerry

New member
Joined
Jun 25, 2020
Messages
16
Hi, your setup is nearly the same as mine. Any luck getting sleep to work?
Haven't tried to resolve the sleep issue because I never sleep;).
Basically I turn the sleep option off by running this command in terminal.
Bash:
sudo pmset -a sleep 0;
Please let me know if you find a way.
 

Niko

New member
Joined
May 17, 2020
Messages
4
You get a like from me for the wallpaper. 😻

Forget the EFI can you send the wallpaper PLZ
 
Top Bottom