Solved Big Open Core problem

Der_Slime

New member
Joined
Feb 25, 2021
Messages
22
Hey guys,

I need help :/

I´m trying to install High Sierra on my PC (with Legacy and no UEFI) and follows the official Open Core Guide. Everything worked fine, well Open core made a little problems, like that my Keyboard (USB) wont work, but nothing Serious. I used two USB sticks with OC (one with the installer and one only with OC for booting into my Harddrive with High sierra for the final instalation)
And now I have the problem. I cant use my Keyboard in OC so I cant choice wich Harddrive I want to use for boot and I cant enter my Mac OS anymore. I tried everything to get enabled the Keyboard in my Config.plist but nothing worked. Can someone please help me?
I´ll upload a ZIP with my current EFI Folder ;D

That is my Hardware

Mainboard: Asus m5a78l-m /USB3
CPU: AMD FX8350
GPU: MSI (Nvidia) Geforce GTX970 Gaming Edition
RAM: 16GB DDR3
Storage: 120GB SSD Windoows 2TB Files (Games, Onedrive and some other Stuff for Windows) 120GB SSD macOS Highsierra
 

Attachments

  • EFI.zip
    8.7 MB · Views: 19

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,297
Try including this with your Drivers. Also the vault script isn't needed there.
 

Attachments

  • OpenUsbKbDxe.efi.zip
    8.2 KB · Views: 7

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,297
You included the driver in the config correct?
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,297
In your config enable KeySupport
 

Der_Slime

New member
Joined
Feb 25, 2021
Messages
22
is enabled. But no work... I dont know why exactly the Keyboard wont work in Opencore but its very sad :/
 

Der_Slime

New member
Joined
Feb 25, 2021
Messages
22
Well I found the fix for my problem... I have to use the PS2 keyboard driver efi to use my Keyboard. Now its very laggy in opencanopy but I can deal with it ;D
 

RandomAccessMonkey

New member
Joined
Jul 15, 2021
Messages
1
Hi I have the same mobo and FX 6300 Black with Radeon R9 GPU, latest version of open core and trying to use Big Sur.

I was wondering if you can provide images or go through your BIOS settings as there is no UEFI support for this MOBO.
 
Top Bottom