AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi, Ultra & Master - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

Would you like me to change the EFI SMBios over to MacPro7,1 from OpenCore V0.7.0 onwards?

  • Yes change it to SMBios MacPro7,1

    Votes: 12 75.0%
  • No keep it at SMBios iMacPro1,1

    Votes: 2 12.5%
  • Have Both 7,1 and 1,1 available to download

    Votes: 2 12.5%

  • Total voters
    16
  • Poll closed .

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
downloaded, this installer is too slow because im using macos in virtual machine
Patients Buddy, It will be worth it if it works. (y)

I forgot to swap the ethernet kext to the one you need to use for high Sierra, Replace the kext with the correct one or ethernet won't work. As you already know its a simple copy and replace with no touching the config.plist needed.
 

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
good and follow the instructions carefully.
Im creating a EFI for you right now
I don't know why, but the macos virtual machine is crushed, now I'm trying again for the third time to build the installer with BuildmacOSInstallApp.command
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
I don't know why, but the macos virtual machine is crushed, now I'm trying again for the third time to build the installer with BuildmacOSInstallApp.command
Assign more memory and cores to the virtual box bud.
Why don't you do it in windows instead? It's no harder really.
And I would highly advise doing it the way Dortonia say to create a USB Installer.
 

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
Amico dei pazienti, ne varrà la pena se funziona. (y)

Ho dimenticato di scambiare il kext ethernet con quello che devi usare per High Sierra, sostituisci il kext con quello corretto o ethernet non funzionerà. Come già sai, è una semplice copia e sostituisci senza toccare il file config.plist necessario.
yesyes, ty mate. as soon as I create the usb and add the file I'll let you know.
 

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
Assign more memory and cores to the virtual box bud.
Why don't you do it in windows instead? It's no harder really.
And I would highly advise doing it the way Dortonia say to create a USB Installer.
on windows from an error and I don't know how to fix it, the important thing is to get to the finish line even if it takes a little more time at least it gets there
 

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
Assign more memory and cores to the virtual box bud.
Why don't you do it in windows instead? It's no harder really.
And I would highly advise doing it the way Dortonia say to create a USB Installer.
it doesn't make me create usb. I am attaching a photo, I tried with 2 usb a 2.0 and a 3.0 Error.PNG
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
If you can’t do it via a virtual machine then your only other option would be to do it in windows.
I create usb installers all the time via windows or macOS using the same method as you are trying to do and I’ve never had a problem doing it.
i used the efi you gave me without touching anything just adding the new kexts, it gives the same error as before.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
i used the efi you gave me without touching anything just adding the new kexts, it gives the same error as before.
I’m all out of ideas for now. I have no idea why this is happening to you.
What revision bios are you using?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
It’s because they have updated to F32, it’s not on all the boards yet as they had a problem with there server but it’s available to download. F31 works fine anyway
could it be that putting "load optimized default" loads something wrong in the BIOS? I don't know what to think, if I have a faulty motherboard or something ... I hope you get some ideas
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
could it be that putting "load optimized default" loads something wrong in the BIOS? I don't know what to think, if I have a faulty motherboard or something ... I hope you get some ideas
If you want to try reflashing your bios then you can download F32 Release from here.
Im testing F32 with my memory and PBO tuned settings on the X570 Pro right now and it seems fine so far.
 

Andyg1983

New member
Joined
Jan 20, 2021
Messages
3
Hi mate,

Just wanted to thanks you for the work you put in to the EFI and supporting everyone.

My setup is a X570 Pro, 3950x and Nitro Vega 64... Had some issues with a black screen until I removed the boot argument agdpmod=pikera which seems obvious but I have had previous builds where that didn't hurt.

Probs try upgrading the Bios later from F11 but first things first time to get rid of the minging desktop background.

Cheers for this it is much appreciated.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Hi mate,

Just wanted to thanks you for the work you put in to the EFI and supporting everyone.

My setup is a X570 Pro, 3950x and Nitro Vega 64... Had some issues with a black screen until I removed the boot argument agdpmod=pikera which seems obvious but I have had previous builds where that didn't hurt.

Probs try upgrading the Bios later from F11 but first things first time to get rid of the minging desktop background.

Cheers for this it is much appreciated.
Thanks for the kind words buddy, It’s much appreciated :)

Do update your bios yes but wait until Revision F32 goes live on there webpage.
 

svan71

Donator
Donator
Joined
Oct 24, 2020
Messages
48
Can you tell me if there is a way to change the resolution of the picker screen 4k is to small for me.

Thanks
 
Last edited:

sasaf01

Member
Joined
Jan 5, 2021
Messages
41
Se vuoi provare a eseguire il reflash del tuo BIOS, puoi scaricare la versione F32 da qui.
[URL unfurl = "true"] https://www.tweaktownforum.com/foru...dors/gigabyte/28656-gigabyte-latest-beta-bios [/ URL]
Sto testando F32 con la mia memoria e le impostazioni ottimizzate per PBO sull'X570 Pro in questo momento e finora sembra

If you want to try reflashing your bios then you can download F32 Release from here.
Im testing F32 with my memory and PBO tuned settings on the X570 Pro right now and it seems fine so far.
Is secure the source?it is not better to wait for the official one on the gigabyte site?
 
Last edited:

Andyg1983

New member
Joined
Jan 20, 2021
Messages
3
Thanks for the kind words buddy, It’s much appreciated :)

Do update your bios yes but wait until Revision F32 goes live on there webpage.
Great will keep an on that, I have a 6900xt that is being wasted in Windows until the macOS Drivers come out so will do a bios update if that ever gets support.

Thanks again.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Can you tell me if there is a way to change the resolution of the picker screen 4k is to small for me.

Thanks
Go into the Config.plist and under UEFI -> Output -> Resolution change it from Max and set the resolution you want.
Example - Output = [email protected]

Is secure the source?it is not better to wait for the official one on the gigabyte site?
Its from gigabyte themselves, this is where they post the beta BiOS for Users to try, If you look who posts them you can see he’s from gigabyte. F32 is not beta it’s release. 👍
 

svan71

Donator
Donator
Joined
Oct 24, 2020
Messages
48
Go into the Config.plist and under UEFI -> Output -> Resolution change it from Max and set the resolution you want.
Example - Output = [email protected]


Its from gigabyte themselves, this is where they post the beta BiOS for Users to try, If you look who posts them you can see he’s from gigabyte. F32 is not beta it’s release. 👍
Your the best man, thanks again. I have been using a GT 710 and things have been fine. I would love to use a ASUS STRIX R7 370 I have but it requires a few edits that are above my pay grade :( Could you help me with that?
 
Top Bottom