Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#53320
ryzentosh.png
Thanks everyone for sharing your success story and tips. I have successfully installed the 10.15.2 Catalina on my newly built PC, see my signature for build detail.

First of all, I almost gave up after a few unsuccessful attempts with OC and then Clover:
Code: Select all
agdpmod=pikera
  • Then I switched to Clover, got stuck at the Only 128/256 slide values are useable issue (the problem was that the clover patch only works until 10.15.1)
  • Then I managed to find a 10.15.1 image, gave it another try with Clover, failed again, somewhere I forgot where.
I almost gave up, until I looked at one post whose build is very close to mine: viewtopic.php?f=61&t=9437, the person also posted their EFI, so I downloaded it, gave it a try, then for the first time on my PC, I saw the macOS installer loaded, though there's this very weird issue with the display that I cannot continue with the installation (like the one mentioned here: viewtopic.php?p=52103#p52103).

I remembered seeing some post talking about 5700xt not fully working on 10.15.1 but fixed on 10.15.2, so I got the 10.15.2 image, again, made the installer.

OMG, I then saw a fully functional installer.

Got it installed on my 250GB SSD (retired from a previous mac), tried and almost everything works, but with a few minor issues such as:
  • The screen freeze and mouse and keyboard won't react after 15 minutes or so (where the screen would freeze).
  • The AirDrop sometimes works with a little busy hesitation(cannot tell exactly how, BTW, I have the Fenvi T919 card)
  • Sleep won't work.
In the next few days, I did a few things to continue the hackintoshing:
  • Changed the SMBIOS information
  • Did another installation on a new SSD
  • Removed unnecessary stuffs from the EFI
  • Removed unnecessary stuffs from the config.plist
  • Upgraded the OC to 0.5.3 (it turns out the WhateverGreen on the EFI I used is not latest, so I upgraded it)
This is how the EFI folder looks like now:
Code: Select all
├── BOOT
│   └── BOOTx64.efi
└── OC
    ├── ACPI
    │   └── SSDT-EC-AMD.aml
    ├── Drivers
    │   ├── ApfsDriverLoader.efi
    │   ├── FwRuntimeServices.efi
    │   ├── HFSPlus.efi
    │   └── VirtualSmc.efi
    ├── Kexts
    │   ├── AppleALC.kext
    │   ├── AppleMCEReporterDisabler.kext
    │   ├── Lilu.kext
    │   ├── NullCPUPowerManagement.kext
    │   ├── VirtualSMC.kext
    │   └── WhateverGreen.kext
    ├── OpenCore.efi
    ├── Tools
    └── config.plist
What works:
  • Dual boot (default EFI is the OC, bootcamp to windows).
  • Audio: tested once but I have a Scarlett 2i2, I either use it or the monitor's audio output.
  • Video: the GPU works, did not test with too many apps, GeekBench score is ok.
  • Wifi & Bluetooth: both works OOB since I got the Fenvi T919, so does the AirDrop and iMessage, etc.
  • Sleep works if I connect my monitor's hub to the MOBO's USB 2.0 port.
What does not work:
  • Sleep does not work if I connect my monitor's hub to the MOBO's USB 3.0 port.
  • Sidecar does not work - black screen on iPad.
What I have not tested:
  • Ethernet: I don't have an ethernet port close to where I put my PC at.
  • Adobe: too bad I did not know that Lightroom does not work on AMD hackintosh - which is the only reason I put $10 a month for. I'll give it another try if there's any news, but I still have other macs and I don't use lightroom on a computer very often, either.
This is my second hackintosh build after a few years of the first one(I did it once when I was in college on a HP laptop), this is different from whatever I remember it was like, it could be pretty simple if I had added the agdpmod=pikera, or got a cheaper GPU.
You do not have the required permissions to view the files attached to this post.
hansibansix, HKim liked this

 Advertising

#53786
amd-osx.com is misconfigured. Every person has efi in all directions. In different topics. So i find this: https://sharvane.conocer.xyz/folder/4/catalina and this: https://sharvane.conocer.xyz/folder/1/Mojave
to be organized. If it work i can think for more simple ways too... So if someone want they can use: https://sharvane.conocer.xyz and when they register they can share they slover, open core or etc. files in order and so everybody can
Installer doesn't detect M.2 SSD

I can boot to the installer without problems, howe[…]

Of course, if all the PCIe slots are full or ina[…]

Hi all, sorry for my english ^^" I'm try to i[…]

Hi, I have same MB with 2700 CPU and RX 580 runni[…]