Welcome to AMD OS X

Why not register now to gain full access.

#52673
Hi, I've been enjoying your AMD OS X builds, and finally prepared a new machine for myself to join you.
So far, I've followed the Opencore Vanilla Desktop Guide https://khronokernel-2.gitbook.io/openc ... top-guide/

Current State:
iCloud, FaceTime, iMessage, and hand-off works.

[Geekbench 5]
CPU: https://browser.geekbench.com/v5/cpu/697878
Metal: https://browser.geekbench.com/v5/compute/291083
OpenCL: https://browser.geekbench.com/v5/compute/291073

Problems:
[Cleared] I'm stuck at installing macOS Mojave 10.14.6 from my USB with UFI partition(OC) and 'Install mac OS Mojave' partition. It stops showing 'End RandomSeed'. Note: Because the initial problem with the headline 'End RandomSeed' was cleared, I've changed the title.
No build-in audio working
No second monitor output
Parallels Desktop: Running VM on Parallels Desktop clashes to reboot (This is a big headache for me because my old VM environment is hardly be replaced... Before I run the VM, Parallels warns that the current setup lacks the virtualization support and only 1 CPU could be utilized (So, it should at least run in limited VM spec). Welcome any workaround or advice!
12/5 I've found my Windows 8 VM can run but Win10 VM not (both share same settings at Parallels side)...

Troubleshoot log:
<Shoot 1> ['End Random Seed' problem, in my case, was due to incomplete CPU (17th) patch.]
Could this be due to I skipped SSDT-EC-AMD in ACPI? I thought it does not apply for Mojave, and my EC shows ap as 'PNP0A03,0' so I did not put anything myself to ACPI in config.plist.
11/29- Enabling/disabling "Above 4G decoding" did not help.
11/30 Updating information & What I've done: [Cleared the End RandomSeed issue]
- Realized I've been trying un-supported macOS ver (old) but updating installer to Mojave 10.14.6 (18G103) did not improve the situation.
- Trying booting from every USB ports
- Trying different settings enabling/disabling : ShrinkMemoryMap.kext, [SMCProcessor.kext; SMCSuperIO.kext], SmallTreeIntel82576.kext
-[unforced error found] I went through the Opencore Vanilla Desktop Guide and found that I was doing dumb at merging the CPU patches. (There was an apparently larger number of entries...so, I deleted them all and put 17th patch again --> Worked!)

Below are Kexts and Drivers I put in OC
Kexts:
AppleALC; Lilu; NullCPUPowerManagement; SmallTreeIntel82576; SMCProcessor; SMCSuperIO; VirtualSMC; WhateverGreen;
Drivers:
ApfsDriverLoader; FwRuntimeServices; HFSPlus; UsbKbDxe; VBoxHfs; VirtualSmc;
Hardware:
CPU: AMD Ryzen 7 3700X; M/B: Gigabyte X570 AORUS Pro [BIOS: F10 8AMTS004]; RAM: Crucial 16GB DDR4-3200 x2; GPU: MSI Radeon RX570 8GB; SSD: Crucial P1 M.2 2280 1TB; NIC: Broadcom WiFi/Bluetooth (Fenvi FV-T919)

 Advertising

Just checked on other install, not working.

@QuickTime , any chance you can share your EFI fo[…]

I had already ordered Intel components to build a […]

yes thats why I am using xfx rx580 for the instal[…]