Welcome to AMD OS X

Why not register now to gain full access.

#52576
Progress so far: Installed - working on details :)

Image
Important - If you want to use WhateverGreen.kext than remember to add agdpmod=pikera in boot arguments of config.plist

I was following the guide on main page (https://vanilla.amd-osx.com/) using Clover just with modified SmallTree-Intel-211-AT-PCIe-GBE.kext.

Ethernet Intel(R) I211 Gigabit Network Connection issue fixed thanks to @larny1:
SmallTree-Intel-211-AT-PCIe-GBE.kext_.zip

When you are installing from USB after first reboot you will get strange screen (top of it black and bottom letters saying at the end ASP: Shutting down). Just give it about 15-20 minutes, it's installing and it will restart.
After the restart you will get a welcome window to set up your Mac.

Used kexts:
AppleALC.kext
AppleMCEReporterDisabler.kext
Lilu.kext
NullCPUPowerManagement.kext
SmallTree-Intel-211-AT-PCIe-GBE.kext
VirtualSMC.kext
WhateverGreen.kext

config.plist modifications:
For WhateverGreen to work:
Code: Select all
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v npci=0x2000 debug=0x100 keepsyms=1 agdpmod=pikera</string>
		<key>DefaultLoader</key>
		<string>boot.efi</string>
		<key>DefaultVolume</key>
		<string>LastBootedVolume</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>NeverHibernate</key>
		<true/>
		<key>Timeout</key>
		<integer>10</integer>
		<key>XMPDetection</key>
		<string>Yes</string>
	</dict>
For audio with AppleALC.kext:
Code: Select all
<key>Audio</key>
		<dict>
			<key>AFGLowPowerState</key>
			<true/>
			<key>Inject</key>
			<integer>7</integer>
			<key>ResetHDA</key>
			<true/>
		</dict>
Audio working in the system after changing output to Internal Speakers.

After installation I followed: https://amd-osx.com/faq/#post-installation

My config.plist here:
config.plist.zip
You do not have the required permissions to view the files attached to this post.
Last edited by sloniupl on Mon Nov 25, 2019 9:22 pm, edited 13 times in total.
Nedjo liked this

 Advertising

#52579
I've tried these following, but still couldn't solve the problem, but you should try.
1. IntelMausiEthernet.kext
2. SmallTreeIntel82576.kext
3. SmallTree-Intel-211-AT-PCIe-GBE.kext

Tring to find other kext.

Some one said that even though there is no networking connection, the installation can be continued, which doesn't happen to me.
#52588
Hi,
Try to add at the end of the file Info.plist of your kext (after OSBundleLibraries block) :
<key>OSBundleRequired</key>
<string>Root</string>
sloniupl liked this
#52592
Try with this Kext : SmallTree-Intel-211-AT-PCIe-GBE.kext
https://drive.google.com/file/d/1lJhg84 ... wSbIl/view
sloniupl liked this
#52754
Hombre wrote:I am using your file but I get to the install for Catalina screen. However no USB/Keyboard works to install. Any help appreciated.
try unplug your keyboard then plug in again. For me this build's USB doesn't work everytime I start up. It might work for you.
#52835
Does sleep works on your setup? I have same platform.
sloniupl wrote: Sat Nov 23, 2019 10:19 pm Progress so far: Installed - working on details :)

Image
Important - If you want to use WhateverGreen.kext than remember to add agdpmod=pikera in boot arguments of config.plist

I was following the guide on main page (https://vanilla.amd-osx.com/) using Clover just with modified SmallTree-Intel-211-AT-PCIe-GBE.kext.

Ethernet Intel(R) I211 Gigabit Network Connection issue fixed thanks to @larny1:
SmallTree-Intel-211-AT-PCIe-GBE.kext_.zip

When you are installing from USB after first reboot you will get strange screen (top of it black and bottom letters saying at the end ASP: Shutting down). Just give it about 15-20 minutes, it's installing and it will restart.
After the restart you will get a welcome window to set up your Mac.

Used kexts:
AppleALC.kext
AppleMCEReporterDisabler.kext
Lilu.kext
NullCPUPowerManagement.kext
SmallTree-Intel-211-AT-PCIe-GBE.kext
VirtualSMC.kext
WhateverGreen.kext

config.plist modifications:
For WhateverGreen to work:
Code: Select all
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v npci=0x2000 debug=0x100 keepsyms=1 agdpmod=pikera</string>
		<key>DefaultLoader</key>
		<string>boot.efi</string>
		<key>DefaultVolume</key>
		<string>LastBootedVolume</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>NeverHibernate</key>
		<true/>
		<key>Timeout</key>
		<integer>10</integer>
		<key>XMPDetection</key>
		<string>Yes</string>
	</dict>
For audio with AppleALC.kext:
Code: Select all
<key>Audio</key>
		<dict>
			<key>AFGLowPowerState</key>
			<true/>
			<key>Inject</key>
			<integer>7</integer>
			<key>ResetHDA</key>
			<true/>
		</dict>
Audio working in the system after changing output to Internal Speakers.

After installation I followed: https://amd-osx.com/faq/#post-installation

My config.plist here:
config.plist.zip

Just checked on other install, not working.

@QuickTime , any chance you can share your EFI fo[…]

I had already ordered Intel components to build a […]

yes thats why I am using xfx rx580 for the instal[…]