Welcome to AMD OS X

Why not register now to gain full access.

I've had to use windows to create and configure my USB install key (gibMacOS doesn't run correctly on my 2006 MacBook Pro running 10.6.8 with python 3.7.0).

When I expanded this topic's EFI.zip, it created the usual "._" files and directories for resource forks (as well as a "__MACOSX" directory). Is it safe to just delete these "._" files, or do I have to expand this on a Mac?
Post Merged
I tried deleting them and using the EFI on the installer, and it seems to work.

However, now I'm having the problem that the Installer says an internet connection is required for installation. Is this normal? Do I need to create new serial numbers before I try this? How do I create new serial number for an OpenCore based USB install when I don't have a Mac to run Clover or OpenCore configuration tools on?
Post Merged
I found the OpenCore Vanilla Desktop Guide and got them generated successfully.
Post Merged
I'm having more serious problems with the install: It keeps trying to contact Apple's servers, the installer log file says the connection is timing out. I couldn't save the log file so I took pictures and will type them in here:
Code: Select all
iMac-Pro osinstallersetupd[636]: Using product <OSISPredicateUpdateInstallerProduct: 0x7fc060d12a30> at distance 25
iMac-Pro osinstallersetupd[636]: OSISPredicateUpdateProduct: Incompatible Apps List: Timed out loading catalog
iMac-Pro osinstallersetupd[636]: OSISPredicateUpdateProduct: OS Installation Payload: Timed out loading catalog
iMac-Pro osinstallersetupd[636]: OSISPredicateUpdateProduct: OS Installation Payload: No products found.
iMac-Pro osinstallersetupd[636]: OSISPredicateUpdateProduct: Incompatible Apps List:  No products found.
iMac-Pro osinstallersetupd[636]: Failed to find incompatible apps list on software update catalog
iMac-Pro osinstallersetupd[636]: Predicate update product fetch failed with error: Error Domain=com.apple.OSInstallerSetup.error Code=300 "The recovery server could not be contacted." UserInfo={NSLocalizedDescription=The recovery server could not be contacted.}


HackeyMac liked this
Thanks! Trying it now.

That one is a lot smaller than the one I've been using. I've been using the v2.2.2 driver from here: https://github.com/Mieze/RTL8111_driver_for_OS_X/releases
Post Merged
Doh! I was looking at the size of the zip packages. The kext's are actually the same size.
It's the same kext with a small modification to the Info.plist to allow Clover to use it in the recovery enviroment.
No improvement with that version of RTL8111. Still the exact same error and messages.

BTW: I'm using OpenCore. I downloaded the EFI.zip from the first post to this topic.
Shouldn't be an issue on OpenCore. Check your bios date/time is correct. When you boot the installer before you start installing open Terminal and run this command,
Code: Select all
ntpdate -u time.apple.com
Then start installing.
I couldn't use that command, but I didn't need to: The time in the bios was 12 hours off (I was half asleep when I set it weeks ago, and didn't notice that it was in 24 hour format).

I got into the installer, but it told me that it can't install to any of the disks. In particular, it gave this reason for the pcie nvme disk I want to install to:

"You may not install to the volume because the computer is missing a firmware partition."

It was formatted as HFS Extended Journaled with a guid partition table. I tried reformatting/partitioning, but nothing worked until I gave in and erased it as an APFS volume. It's installing now.

Is the installation process always supposed to download off the servers? I'd much rather have the entire installation done from the USB key.
Did pressing "Esc" helps you for a manual boot menu ? or you can check the config.plist if boot menu is hide
Catalina 10.15.2 is installed now. I have the EFI copied over onto the boot volume, so I can boot without the USB key.

Now I have to get Sleep working, get FileVault enabled, and hide all the ugly text that flies by while booting.
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7

thank you very much) :thumbup: :D

Stuck on VirtualSMC, Help

Check your BIOS settings, APU/Integrated graph[…]

First try

If I'm correct that uses a AMD G-T56N which is not[…]

heyy, thank you for this, helped so much, but...[…]