Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: ecpowers
#47990
Dear members!

Yesterday I got MacOS Mojave 10.14.4 installed on my PC, without any issue! However it seems the GPU is underperforming in at least the Geekbench 4.0 OpenCL test. Coming in at 44k rather than about a 180k-ish score.

I've done a fair bit of searching and ended up installing Lilu, whatevergreen and an modified PowerPlay table using VegaTab. My score has increased somewhat to about 49k, but nothing to write home about.

Specs:

AMD Ryzen 7 2700 @ 4.12GHz 1.3v
ASUS Prime X470-Pro
G.SKill Ripjaws V 32GB 3600C19 @ 3400C16
Gigabyte Radeon RX Vega 64 LE
Samsung PM981 512GB NVME (Windows drive)
2x Micron M600 512GB RAID0 (Game disks)
Intel 660p 1TB NVME (MacOS 10.14.4)
Corsair HX1000V2

https://browser.geekbench.com/v4/compute/4029801

Can anyone test and compare scores to mine? Or point me in the right direction on how to fix it?

Thanks in advance!!

 Advertising

User avatar
by: majors
#48043
I have similar issues with the RX 580. Getting around 36K bench in Open CL Geekbench, vs 136K on the same machine in windows.

I also ran something called MetalBench (found it on igpu.io) and the metal benchmarks seem on par with what people there were reporting with Rx580s so I'm not really sure whats going on and I haven't found any answers yet!
User avatar
by: kyobits
#48075
I am having this issue as well with my RX580. Metal seems to work great but anything with OpenCL or OpenGL has poor performance. I am using the Vanilla plist, I am trying to find a fix. If I find anything I will post back here. I will say, being a long time Hackintosher (if that's a word), graphics performance is always hit and miss even on Intel.
User avatar
by: kyobits
#48079
moonman wrote:the reason behind the bad performance is, that apple doesn't maintain opencl/opengl anymore to push metal on their users :|
You may be right. The weird thing is, if I run the Uniengine Valley benchmark on my computer, it runs about 60 fps until it changes scenes, then it drops to around 4 fps. It's very inconsistent, but if I run the same benchmark on a 2014 Mac Mini that I have access to (Intel graphics), it runs smoothly (though at much lower fps).
User avatar
by: ToFailToWin
#48099
If you're trying to game , game on High Sierra, but if not and its just for productivity and video editing. stay on Mojave

Hey @skydiver71903 would you mind sharing the lis[…]

Not booting from USB STick

thank you, will try :) Post Merged it worked w[…]

Hi all, Have a watercooled 3900x/RadeonVII build […]

Same problem over here with a RX570.. getting 40k […]