Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: denijsonc
JurassicOSX wrote: Sat Mar 02, 2019 5:25 pm How would I enter the boot flag? I have a Realtek ALC892 codec
Hello,i have the same audio card model ALC892 with you,and worked on mojave 10.14.1 but didn't work on 10.14.3 using boot flag :"Alcid=1".If u have sovled this problem .Plz tell me how to fix it.thanks :D


User avatar
by: JurassicOSX
I am staying at 10.14.1 and I did use the boot flag :"Alcid=1"
User avatar
by: revrites
problems with sound, works only through hdmi, help please

OS: MacOS 10.14.1
CPU: AMD Ryzen 7 1800X @4.1 GHz,
MOBO: Asus Crosshair Hero VI x370
GPU: Sapphire RX580 Nitro+ 4GB
RAM:8GB DDR4 @ 3200 MHz
User avatar
by: bernek
Works with 10.13.6 using MSI B350M Pro VD PLUS board with ALC887 but I still have crackling sounds ... not that often but still do ... layout 11 btw.
User avatar
by: setterlee
Try with alcid=7, works for me with the audio but the microphone don't work
Post Merged
mikiveliki wrote: Wed Mar 06, 2019 4:08 pm I do not know which layout ID to use because there are lot of them for my chip (Realtek ALC887 0x100202, 0x100302, layout 1, 2, 3, 5, 7, 11, 13, 17, 18, 20, 33, 40, 50, 99). my motherboard is asus prime b350 plus and codec is realtek alc887. please suggestion. and if that make sense, I copied applealc.kext to other and EFI/CLOVER/kexts/10.xx ...
Try with alcid=7, works for me to get the audio working but the microphone won't work...
User avatar
by: Mod76
Someone got the Alc 1220 / S1220A got working on recent MSI Motherboard working ?
Which alc-id should i use on a MSI B450 Gaming Pro Carbon AC?
User avatar
by: bernek
I got it working with a fresh install using the new guides. The AppleALC was already included set my id (11 for me) and it works no more dropouts and such but audio/video goes out of sync after 2-3 minutes of watching a youtube video for example ... after more than 15-30 minutes is so badly out of sync that becomes annoying.

What could be the problem ?
User avatar
by: cy2k
I can't get onboard audio to work even after trying every layout id for ALC892. Help? :thumbup:

Specs in signature below.

IORegistryExplorer and config.plist attached.

You do not have the required permissions to view the files attached to this post.
User avatar
by: jotakinhan
Hi, I have 10.14.1, Ryzen 1700x, and Crosshair 6 Hero MB. Otherwise perfectly working, also sound with AppleALC, but i cannot get my headset mic working? Anyone got their mic working with this mb, or other x370 MB? I think my problem is related to S1220 audio, there seems to be support for S1220A, but it is apparently a bit different (https://rog.asus.com/forum/showthread.p ... difference). I heard that pink mic ports never work with AppleALC, is that true?

But, wich version of Catalina worked with you?[…]

I have a very similar configuration. I keep gettin[…]

Hello today I decided to update my system after a […]

Hello... Thanks for sharing your experince. Please[…]