Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: Dave Corley
#44827
Hey All! I've been trying to get my OS X Virtual machine running properly over here but haven't had much luck. My build is an Asrock X399 Taichi Ultimate (ALC1220) with a 1950x and gtx 1080, using unRAID 6.6.5 as the host OS. I managed to get an installation working with GPU acceleration and everything without special kernels et cetera, but audio's caused me a ton of trouble. When using VoodooHDA I get really horrible audio quality, hence this thread.

So I tried to follow the guide here (viewtopic.php?f=24&t=4880) , but I get this error:
Error: no IOReg/HDEF; BIOS/.../HD Audio/disabled or ACPI problem
But the audio devices ARE recognized if I simply add voodooHDA.kext and reboot. They just sound so terrible as to be useless. I've tried looking at iOREG myself and couldn't find the @1B entry that would suggest a codec is there, but Toleda's guide that discussed that and pretty much every other led to solutions that seemed specific to intel parts. My device ID does show up in IOREG, though. I figure it's also worth mentioning my audio works fine in every other OS, minus occasional issues resetting the controller due to some IOMMU issues mostly resulting from my own laziness.

I tried following ydeng's original post to install everything manually, but same problem, no audio devices.

All the files asked for in the original thread are attached, minus a few things like my serial etc. Many thanks to anyone who can help.
You do not have the required permissions to view the files attached to this post.

 Advertising

Catalina ??

Sweet!!!!!

Hi Zool, in answer to your question Yes to everyth[…]

Hi man in the suit, I would try using the HDD from[…]

I think I read somewhere that a guy having the sam[…]