Welcome to AMD OS X

Why not register now to gain full access.

#44823
Hi, I already own a Ryzen 7 2700x with an Asus Prime B350M-A: I put the patched AMD kernel by Shanee for 10.13.6, patched IONetworkingFamily.kext and System.kext in an existing High Sierra 10.13.6 Intel installation, my system booted perfectly fine and is really fast.

Using THE SAME disk and kernel, just attaching it to a Gigabyte X399 Aorus Gaming 7 and a Threadripper 2990wx (Bios 11e), i get this:

https://www.dropbox.com/s/6ve236yhp0ub9 ... 5.mp4?dl=0

which is basically this screenshot:
https://www.dropbox.com/s/3v5rqh8olsox8 ... 3.jpg?dl=0

Using cpus=1 flag or npci=0x2000 doesn't make any difference... Even adding VoodooTSCSyncAMD.kext to SLE and recreating the prelinkedkernel cannot change anything... do I need a patched kernel or a DSDT?

If I try an existing Sierra installation that works for my Ryzen I get an Invalid kernel opcode error and a consequent panic in AppleACPIPlatform.kext.

Finally this is what I get using a freshly created installation pen drive with HighSierraV3Unofficial.dmg:
https://www.dropbox.com/s/pvhm7flkzo3zc ... 8.jpg?dl=0

Please give me some hints... do I need perhaps a similar patch? https://osx86.org/forums/topic/20691-ex ... rk/?page=2
Post Merged
DSDT not bootable x399 F10.zip
DSDT bootable Ryzen.zip
It seems that since F10 BIOS osx is not bootable anymore, using a patched dsdt from my Ryzen setup partially works but system cannot show the gui... Can you help me patching x399 aorus dsdt? I'll post the two files right now!
Post Merged
Solved editing CPU's SSDT, read the solution!!! https://www.insanelymac.com/forum/topic ... nt-2659334

Happy AMD Hackintoshing :)
You do not have the required permissions to view the files attached to this post.

 Advertising

Problem at installation reboot

Looks like some files are missing from the install[…]

Help for install

If the disk is not showing up, in the same sceen w[…]

Have you tried injecting Lilu and Whatevergreen in[…]

The forbidden sign appears most likely because you[…]