Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#44007
OS
High Sierra 10.3.3

Image
Image


Specs
CPU: Ryzen 5 2600
MOTHERBOARD: AORUS B450 I PRO WIFI
GPU: Asus GTX 1070 Ti TURBO
SSD1: Samsung 970 EVO 250Gb (MAC)
SSD2: Crucial BX500 250gb (W10)
RAM : Corsair Vengeance 2x8Gb 3000Mhz

Peripherirals it´s worth to mention
DONGLE: Asus BT-400
KEYBOARD: Matias Wireless Aluminum Keyboard
MOUSE: Logitech MX Master 2S
DISPLAY: Dell u3417w

What works
- All USB Ports (Including monitor built-in USBs 2x 3.0)
- Ethernet
- Full Resolution 3440 x 1440 @ 60Hz
- App Store
- Audio HDMI Entry (Voodoo kext)
- Audio Line-out green rear (No glows appreciated so far, if glows then AppleHDA)
- BT motherboard card (had to use dongle because my keyboard wasn't compatible, not even on w10. However I was able to test it with my phone and smartwatch before disable it )
- BT Dongle (Sometimes not detected at restarts on 3.0 ports, works seamlessly after plug it into a 3.1)
- Wireless keyboard and mouse
- Monitor: Mobo voltages, fan rpms and ssd, cpu and ambient temps (DIMM voltage is wrong and is measuring something else)
- NVME SSD recognition (After patch) and trim ssd

Haven´t tried yet
- iTunes, iCloud, iMessage, FaceTime (And no interest to try it, I guess their behaviour will be similar to rest of builds )
- Games
- Sleep/Wake

What doesn't work
Obviously the wireless keyboard doesn't work at boot time, however I only use windows to play games once a week at most so for my use case it is ok. I would recommend you to purchase a wired keyboard if you change between OS everyday.

Summary
Installs were on 970 SSD, tested with AMDHS_Installer and HighSierraAMD V3 Unofficial. There wasn't any noticeable difference, I stayed with Unofficial V3 only because was the last one I tested it.

The temps are 38-40 ºC and a steady 45ºC after an hour. A bit high but it is not a hackintosh related issue, I get the same measures on W10 (bear in mind it is an itx build and currently doesn't have a lot of airflow). To lower the temps I've ordered a NH-U9S and a case fan that Im sure will lower by 10-15 ºC.

This is my first Hackintosh so if you see some error or something it can be improved please tell me.

If someone has the same specs maybe can be interested in see my repo to have a hint of needed kext and versions. However I recommend to go through the whole process, research by yourself and test configs and kext one by one. https://github.com/jnavb/hackintosh

Acknowledgement
I want to thank the whole amdosx comunity and the people behind the discord channel who were very helpful.
Specially thanks to XLNC, Shaneee, Scooby-Chan, Algrey and NoOne.
Last edited by jergte on Sat Nov 24, 2018 10:30 pm, edited 1 time in total.

 Advertising

#44136
211006 wrote:
Fri Nov 23, 2018 8:16 pm
I have almost the same machine as yours except for a cheaper gpu. I'm wondering what method you used and if you experienced any unforeseen challenges?
Follow this tutorial for BIOS set up https://www.youtube.com/watch?v=RhGxcV7akkw
and install HS V3 Unofficial following the guide from this forum viewtopic.php?t=4127

I got stuck at detecting my NVME sdd, that's all.
#51187
I have the same hardware with gtx 1060 graphics. All works well except onboard wifi. did you able to get it to work?

Thanks
nvidia gpu laggy

I use this driver on my GTX 1070: https://images.n[…]

Install the nvidia web driver for 10.13.6 here: ht[…]

Hey guys! The issue is still present even with the[…]

Whats your system specs ? Post a dump using dar[…]