Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: tikizondo94
#42639
Running 10.13.5 with and having an issue with my new NVMe drive showing as an external device. Any ideas on fixing this? Ive tried all the "usual" fixes, external icons patch, ahciportinjector.kext etc. Am i missing something??

 Advertising

User avatar
by: Shaneee
#42640
Have you tried the patch from PikerAlpha?
Code: Select all
<dict>
    <key>Comment</key>
    <string>IONVMeFamily Pike R. Alpha Patch#External</string>
    <key>Disabled</key>
    <false/>
    <key>Name</key>
    <string>IONVMeFamily</string>
    <key>Find</key>
    <data>SIXAdAeAiwgBAAAQ</data>
    <key>Replace</key>
    <data>kJCQkJCAiwgBAAAQ</data>
</dict>
User avatar
by: tikizondo94
#42646
Yes sir, Does not seem to make a difference. Also tried latest AHCIPortInjector.kext just to see if it would do anything. Nothing. Attached are my current outputs if that helps. Thanks Shaneee :)
You do not have the required permissions to view the files attached to this post.
User avatar
by: ydeng
#42648
Inject "built-in" property to pci2646,5008 (right above IONVMeController) might help.
User avatar
by: AlGrey
#42649
you can use this patch in your config.plist
You do not have the required permissions to view the files attached to this post.
User avatar
by: tikizondo94
#42652
ydeng wrote:Inject "built-in" property to pci2646,5008 (right above IONVMeController) might help.
How would i go about doing that?
Post Merged
AlGrey wrote:you can use this patch in your config.plist
Im currently using that patch and it has not seemed to make a difference..
User avatar
by: ydeng
#42661
tikizondo94 wrote:
Thu Sep 13, 2018 10:59 pm
ydeng wrote:Inject "built-in" property to pci2646,5008 (right above IONVMeController) might help.
How would i go about doing that?
Post Merged
AlGrey wrote:you can use this patch in your config.plist
DSDT/SSDT like the following:

Device(pci2646,5008)
{
Name(_ADR, 0)
Method (_DSM, 4)
{
If (!Arg2) { Return (Buffer() { 0x03 } ) }
Return (Package()
{
"built-in", 1
})
}
}

Or you can write a small kext to do this https://pikeralpha.wordpress.com/2014/0 ... /#comments. On 13.3 this was internal, right?
#42664
Ive never used this drive on 10.13.3 only on 10.13.5. I just got the NVMe drive yesterday. Cloned my 10.13.5 SSD drive and fired it up. Always shows as external.
Post Merged
Im no pro at SSDT compilation. Anyway you could lend me a hand with this @ydeng?
Post Merged
Solved. AlGrey straightened me out :)
viewtopic.php?f=53&t=5185#p42704
You do not have the required permissions to view the files attached to this post.
AlGrey liked this
OsxAptioFixDrv Error

Hi guys, i installed osx yesterday on m2 samsung […]

Has anyone figured out the issue where the instal[…]

oh,good job,dude, i will try it .

Hi, i've trying to install the macos high sierra b[…]

AMD OS X Advertisements