Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
#42677
I didnt see this issue listed anywhere and hopefully its simple.

Install and instructions all went smooth, with no problems. but when booting from OS disk for 1st time via USB as instructed, during the boot process it freezes on what seems to be a filesystem error.

failed to load kext com.apple.filestems.autofs

hopefully this is something simple. Tried install on 2 diff drives using tutorial procedure, both seemed to go flawlessly until this first boot.

many thanks.

cheers,

 Advertising

#42716
is there any way to get support with this? I know it says questions wont be answered if information is in thread / post already. but in my case, its not. I of course saw the post about apfs.efi, and made sure that this file is in my usb. There is no mention anywhere about manually installing it on the HD or anything like that, and you would think the kernel swap script would do this as well. so please, if anyone knows what my completely reproducible error is, please guide me. I can repro this over and over so it seems like it should be a concrete issue with installation process, but ive followed everything to the letter.

cheers,
#42718
dekkard wrote:is there any way to get support with this? I know it says questions wont be answered if information is in thread / post already. but in my case, its not. I of course saw the post about apfs.efi, and made sure that this file is in my usb. There is no mention anywhere about manually installing it on the HD or anything like that, and you would think the kernel swap script would do this as well. so please, if anyone knows what my completely reproducible error is, please guide me. I can repro this over and over so it seems like it should be a concrete issue with installation process, but ive followed everything to the letter.

cheers,
What kind of video card do you have? is nvidia or amd? because if it is amd the same thing may be happening to me that when I want to start from the hard drive to finish the installation, a black screen appears that I still do not know how to pass to finish
#42731
no, my is not a video card issue, its a very specific error regarding apfs,

"failed to load kext com.apple.filestems.autofs"
Post Merged
just went through tutorial again with fresh drives and virgin system 1950X . Everything went smooth, until first boot from HD via usb launcher.
still get same repeatable error. "failed to load kext com.apple.filestems.autofs"

I verified that the usb installer of HighSierraV3Unofficial.dmg has the apfs.efi installed in both drivers64 and drivers64UEFI as the guide says.

correctly ran the preinstall after first portion of install, and amd script after install. got no errors or anything else that would indicate a problem. but yet, when trying first boot, i get this error. makes no sense. Ive read everything about 4 times and believe im doing it all as instructed.
#42778
I dont know my advice is the *correct* advice but I have my Ryzentosh working 100%, as for your issues, try mounting the EFI of the usb installer, and finding the kext that you need in there. Now I'm just trying to determine performance. I tried Dying Light but not only did the game warn me that it was meant for AMD gpu's but it also ran rather poorly.

Downloading some other games now as we speak, maybe that was an isolated issue. Otherwise I'll just do some benchmarking and see if its worthwhile. Everything else works great except for one NTFS volume that I have that is 3 combined volumes, OSX wont read that at all. I'll have to redo those partitions, my NTFS SSD however works fine.

Edit: Subnautica never ran that great on Windows but it runs far worse on Ryzentosh. I'm sure there are some things I can do to increase performance.

Edit 2: I ran Geekbench and I think I scored reasonably considering the circumstances. https://browser.geekbench.com/v4/cpu/9986014

I'm certainly thinking the bottleneck may be the GPU or the drivers at the very least.
#42782
Why would you game on Hackintosh or Macintosh ? xD the implementation for OpenGL and CL are weak and macOS was never meant for gaming. DirectX peformance is leaps ahead and much smoother. I dual boot and I never even had the idea to game on Hackintosh.

It's just not meant for this. I use it for FCP and Audio work but that's about it.

I just wish I could fix my Shutdown issues that are really annoying and to make all USB ports work ... I don't need FaceTime and iMessage since I have a MBP 15.
  • 1
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
OsxAptioFixDrv Error

Hi guys, i installed osx yesterday on m2 samsung […]

Has anyone figured out the issue where the instal[…]

oh,good job,dude, i will try it .

Hi, i've trying to install the macos high sierra b[…]

AMD OS X Advertisements