Welcome to AMD OS X

Why not register now to gain full access.

My build:
CPU: Ryzen 3600x
Memory: 8G * 4 DDR4 3800(oc, but stable in memtest in Windows)
Motherboard: MSI X470 M7
SSD: Samsung SM961 256G
Intel P4510 2TB (U2 SSD, but this one can't be recognized by MacOS)
Graphic card: Asus 5700xt reference (water cool modded)
Monitor: Samsung C34F791
Couple of USB devices such as keyboard, mouse, Xbox control also are also plugged.

Installed Catalina 10.15.3 successfully and it's OK to login the system and perform couple of tasks(will mention below). However, after shutdown/restart couple times, eventually I will get the error while booting mentioned in the post title. After that, no matter how many times I tried to restart, it always stuck on this particular error.

The installed Catalina works just fine before the error occur, e.g. iMessage, audio, couple apps like Microsoft office & axure.

I tried 2 ways to build the EFI but still got no luck:
1. Follow the guide mentioned here: https://khronokernel-2.gitbook.io/openc ... top-guide/
2. Almost reuse the EFI from a successful story viewtopic.php?f=35&t=9805 but just remove the NVME SSDT.

Also I tried couple times reinstallation and tried to locate which particular SW/configuration cause the issue but still not got a clear pattern. I tried:
1. Enable apple account/Siri during installation and install some apps(office, axure, a vpn client)
2. Not enable apple account related service but just install some apps(office, axure, a vpn client)
3. Only enable apple account and its related services(iCloud, iMessage, Siri, etc...) during installation but not install any apps after installation finished.

Seems all the way mentioned above will some time end up in the particular error.

Could someone help me to understand what could be the cause?
Post Merged

I think I find some pattern regarding the issue but have no idea how to fix it.

Recently, I changed my CPU to Ryzen 1700 and also GPU to RX580. The system works very well since then. No Kernel cache error anymore.

However, today I changed back to 5700XT and add "agdpmod=pikera" flag to the boot argument, after one or two hours usage I again saw the "Kernel cache error" while booting. It seems that 5700xt or the corresponding args should be responsible for the error.

But how to fix it? As it looks that agdpmod=pikera is mandentory in 5700xt and I also got a black screen without the parameter while booting with 5700xt.

Here is my current EFI which is running a RX580, the only difference for 5700xt is just to add the mentioned agdpmod=pikera.
You do not have the required permissions to view the files attached to this post.


Hi, i don't understand how someone ask for help, f[…]

Sorry for the bump. Am searching for answers. We[…]

Catalina 10.15.4 Update Bug?

I have a question for the Hackintosh masters here[…]

I have a macOS APFS drive, a Windows NTFS drive an[…]