Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#53997
hereditarium wrote:
rob_gizza2 wrote:Hi, Can someone share there EFI as have same hardware , X570, 3600x & RX5700 but getting no joy at the moment.

updated in 1st post
Please share with your Boot Files, because you shared folder doesn't work and isn't booting.

 Advertising

#54062
Hello @hereditarium, nice your system works, mine is pretty much the same as yours (same mobo and GPU) and is working in the same way. But I have noticed the GPU perfo in my hackintosh is much worse than on Windows 10, around 40k geekbench points vs 70k when running compute benchmark with Metal.
Firstly I thought it was a bad implementation of the AMD kernel patches for 17h series but I have seen others with good perfo with AMD and this GPU card: https://browser.geekbench.com/v5/compute/446912
Have you managed to get yours running at full power?
I tried with WEG and AGPMInjector.kext with no change at all and now I am completely out of ideas.
#54063
As far as I'm aware PLUG must be working (X86PlatformPlugin must be loaded) for AGPMInjector to work (https://github.com/khronokernel/Opencor ... U-patch.md)
For USB you probably have to map the ports.

I've this working on my X570 (although ITX with fewer ports) but it might give you a starting point: viewtopic.php?f=35&t=9843
Or look for another EFI with with your board, those are a lot more popular than mine.
#54069
Hi chaps,

Well this is my latest EFI directory, I'm no expert and have pulled together as many suggestions into one place as possible.

I now have Usb 3.1 gen 2 working but with poor performance., although all ports are reporting usb3.1 in OS X and not sure that is correct....

Sleep doesn't work.

I have some fan metrics, GPU temp NVME temp, motherboard temp etc... But no CPU

using Amphetamine to help out with sleep

Bluetooth works well - onboard wifi no luck, but using a Link usb wifi to get connectivity, hence airdrop not working nor is airplay.

Performance overall is good, openGL scores are bad, but playing games seems alright and fast, so assuming metal is better. 52FPS in heaven with max detail and full screen on 4k - is this good? - see screenshot

I need to go through the SDDT's to work out a bit more and try to get the name working a bit better.

Ive added the hardware tools to monitor temps, fans, etc...
Post Merged
I need to go through the SDDT's to work out a bit more and try to get the name working a bit better.
sry meant:-
I need to go through the SDDT's to work out a bit more and try to get the NVME working a bit better.
Post Merged
And here is my boot file as well!
Post Merged
hereditarium wrote: Sun Jan 26, 2020 3:11 pm did you made your own - AGPMInjector.kext ??
i dont use USB 3,1 - no ports in my case ;/
and i dont use WiFi
for sleep try use Amphetamine app (set it to infinity)

Hi, no I didn't - I found one, but I have seen these requirements to get it to work:-

AGPMInjector.kext - Apple graphics power management
Must have X86PlatformPlugin to work! & PLUG.

Your GPU device must be labeled as GFX0 in order for the injector to hook into the AGPMController. This can be done by using Lilu with WhateverGreen, SSDT/DSDT property injection or by Device Properties in Clover config.plist.

I haven't managed to work out how to build a DSDT to set the graphics port to GFX0 thought.... :?
You do not have the required permissions to view the files attached to this post.
#54073
I've made some benchamrk testing with different setups. Every benchamark have shown that setup with NullCpu patch and AGPMinjection are slightly better than with default OC settings. Only on Geekbench 5 OpenCl Compute test result is terrible like 8-9k points. So i assume problem is with Geekbench not with our setups.

I've got a very similar x570 Taichi & 3950x se[…]

This is my first build with a Ryzen and first time[…]

@iGPU , This is awesome, thanks! Your EFI confi[…]

thanks for sharing your file. I was struggling for[…]