Welcome to AMD OS X

Why not register now to gain full access.

#53830
Hi all, sorry for my english ^^"
I'm try to install mac os on my amd PC but I have a problem.
I follow the vanilla guide and I created a pen drive usb installation with Catalina.
I past all necessary kexts in kexts/other folder and I pasted config.plist file from the Vanilla repo to CLOVER folder.
After that I follow the guide for the UEFI driver and than I configured the BIOS of by motherboard, but when I start Mac OS installation through clover it freeze at this screen:
IMG_6325.JPG
Could you help me? ^^"
This is my PC configuration:
CPU: Ryzen 5 2600
RAM: 24 GB DDR4 2400
GPU: Radeon RX580
SSD: 256GB SATA
You do not have the required permissions to view the files attached to this post.
Last edited by Mic87DT on Sat Jan 25, 2020 11:13 pm, edited 1 time in total.

 Advertising

User avatar
by: Shaneee
#53836
You've most likely downloaded 10.15.2 which Clover patches don't support. Switch to OpenCore and it'll work.
Mic87DT liked this
User avatar
by: Mic87DT
#53976
Shaneee wrote: Sun Jan 19, 2020 12:40 pm You've most likely downloaded 10.15.2 which Clover patches don't support. Switch to OpenCore and it'll work.
Hi Shaneee, sorry for the delay. Ok, I try to install and configure opencore using the vanilla guide. When I start mac installation. After I chose macos base system installation, on opencore menu, I freeze on black screen.
Could I attach here my config.plist or my efi folder? So you could help me ^^"
User avatar
by: Shaneee
#53979
Most likely missing the kernel patches. See this guide for setting up OC config for AMD, https://khronokernel-2.gitbook.io/openc ... amd-config
User avatar
by: Mic87DT
#53981
I followed that guide to configure config.plist ^^" (I found the link in your guide), and I added kernel patch. But it didn't works.
capture.PNG
capture2.PNG
I think I made same error, but I didn't understand what ^^"
You do not have the required permissions to view the files attached to this post.
#53982
Did you add the AMD kernel patches? https://github.com/AMD-OSX/AMD_Vanilla/tree/opencore
User avatar
by: Mic87DT
#53996
Shaneee wrote:Did you add the AMD kernel patches? https://github.com/AMD-OSX/AMD_Vanilla/tree/opencore
Omg Shaneee, I'm embarrassed. Notepadd++ jocked me ^^"
Now it works! I installed catalina on my amd!!!
I have only 2 issues 1 with ram and 1 with my gpu, but I think I had to open another post on post installation.
Thanks a lot
Shaneee liked this

I was going along thinking everything was just fin[…]

I've got a very similar x570 Taichi & 3950x se[…]

This is my first build with a Ryzen and first time[…]

@iGPU , This is awesome, thanks! Your EFI confi[…]