Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#52820
CPU: 3900x
MB: Asus x570-e
Video Card: Quadro K4200 (this is just a card being used for testing)

Kext:
Lilu
WEG
AppleALC
VirtualSMC
SMCSuperIO
SmallTreeIntel82576
NullCPUpowerManagement
AppleMCEReporterDisabler
HibernationFixup (Thought it might help, made no difference)
USBPorts

So as a test I setup 10.15.1 on a 3900x and Asus x570-e. Everything works other than sleep. When the computer is put to sleep it shuts off the monitors and shuts off the machine and then immediately spins back up and has a kernel panic. Looking at the logs it shows a USB error which makes sense since the ports have never been mapped properly.
Code: Select all
panic(cpu 0 caller ....): Sleep transition timed out after 180 seconds while calling power state change callbacks. 
Suspected bundle: com.appleiokit.IOUSBHostFamily. Thread 0x1679.
There are two controllers, XHC0 and XHC1. Every guide and tool I've used requires them to be renamed to XHC_. I can rename any single one of them to XHC_, but renaming both of them to XHC_ causes the machine to hang on boot right after printing "hid:legacy shim 2". I tried renaming one to XHC_ and the other to EH01 which enables the system to boot but obviously pushes half the ports to USB2 mode only. But for the sake of testing, even when I do so and map the USB ports to limit them to under 15, going to sleep still causes the same kernel panic.

At this point I'm not sure what else I can test. Is it just this MB? Is it all Zen2 chips? Has anyone gotten sleep to work properly on a Zen2 chip and any x570 board?
gopal334 liked this

 Advertising

#52821
I've got the exact same problem with sleep on Catalina with X470 mobo and Ryzen 3600X. Earlier I was on Mojave and had zero issues whatsoever. X370 and B350 are not affected by this bug and on this platforms sleep is working with Catalina. Unfortunately, for now, I guess the best solution is to just downgrade to Mojave (as I did) and wait for the fix.
#53031
Agree...so far everything seems to be working fine except for sleep functionality. The USB powers down and I can hear the SATA drive spin down...but then the fans on the GPU spin up and the machine seems to be basically hung. Hopefully, there will be a solution to this in time.

Thanks for your post! I'm looking into replacing a[…]

Hello! I've been trying to get my OpenCore configu[…]

Fail. Not worked for nvidia gtx 1070

Hi many thanks, would you be able to share your Bo[…]