Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
Screen Shot 2019-12-14 at 7.45.54 PM.png
Update 1 (see at the very end)

CPU: AMD Ryzen 7 3700X
Motherboard: Asus X570 TUF Gaming Plus (Wifi)
RAM: G.Skill 16GBx2 Ripjaw V 3600Mhz C16
HDD: Several SSDs including Samsung NVME 960 EVO 1TB, EVO 860 1TB, Sandisk 3D 2TB
USB : 3.1
GPU: MSI Vega 56 Air Boost
Sound: Motherboard ( AppleALC, layout 1 or 2 )
Sleep: does not work
Monitor: 2 Acer 24" 4k display via display ports
Bootloader: OpenCore 0.5.3
Bluetooth: IOGear Bluetooth dongle BT 4.0
Wifi: TP-Link Archer T9E 802.11AC AC1900
OS: Catalina 10.15.1, successfully upgraded to 10.5.2; Windows 10
System Definition: iMacPro1,1


- AGPMInjector.kext: for GPU power management, using the tool here
- AMD-USB-Map.kext (mapped all ports)
- ACPIMonitor.kext removed and kept only AmdcpuMonitor.kext
- FakeSMC
- AirportBrcmFixup.kext (not necessary for Wifi to work)
- AppleALC.kext
- AppleMCEReporterDisabler.kext: needed to prevent panic does not need with 10.5.2 and iMacPro1,1 system definition
- BrcmBluetoothInjector.kext (not necessary for BT to work)
- BrcmFirmwareData.kext (not necessary for BT to work)
- BrcmPatchRAM3.kext (not necessary for BT to work)
- Lilu.kext
- NullCPUPowerManagement.kext (needed to prevent panic) does not need with experimental "Skylake patch"
- RadeonMonitor.kext
- RealtekRTL8111.kext (although I use wifi but I can connect to ethernet when needed)
- X86PlatformPlugin.kext: did not know how to load it otherwise with SSDT, so I copied it out of Apple's official kext and load it manually for AGPMInjector
- WhateverGreen.kext

What's working
  • Hardware acceleration / Metal
  • Bluetooth / Wifi with USB dongle and TP-Link
  • Intel Bluetooth was working out of box, but I heard after installing Windows and updated the firmware, it stopped working reliably in macOS. So I reverted back to dongle
  • Audio works with AppleALC or Voodoo. I tried alcid=1 or alcid=2 in boot args, both work
  • iCloud / iMessage works OOB
  • RAM can run at 3600Mhz after updating to latest BIOS, at listed 1.35V
  • Monitoring Vega 56, fan speeds, SSD temperature
  • CPU monitoring: using FakeSMC, AmdCPUMonitor, and W836x from standard HWSensors3
Not working
  • Wake/sleep. I tried to map USB and was able to hide onboard Bluetooth and RGB Aura controller. Still cannot sleep. Display will turn dark and a few seconds later the fan will speed up and that is it. It seems to be still related to USB. I also tried to unplug all USB devices and keep only BT dongle; unplugging front panel USB cable from MB. None of these fixed the issue. If anyone using the same Asus X570 TUF Gaming Plus (Wifi) board and was able to do sleep/wake, please let me know how you fixed it.
Next Steps
  • Ordered Fenvi T919, will replace when arrived
Update 1: Dec. 15th 2019
- Figured out how to monitor CPU
- Adopted latest patch to remove NullCPU based on Discord discussion
- Confirmed that I do not need AppleMCEReporterDisabler.kext on 10.5.2 and with iMacPro1,1 system definition
- Injected AGPMInjector for GPU power management

Screen Shot 2019-12-15 at 1.16.37 PM.png
Screen Shot 2019-12-15 at 1.16.54 PM.png
Screen Shot 2019-12-15 at 1.17.06 PM.png
EFI download
- Note that you need to replace with your own serial number etc.
- And this EFI contains the patch to get rid of NullCPU
- This EFI may not work if you have 10.5.1 only
- NOT ALL KEXT included, e.g., did not include Broadcom BT kexts, due to file size. Therefore you need to modify config.plist to the kext you need
EFI for sharing.zip
You do not have the required permissions to view the files attached to this post.
Last edited by QuickTime on Sun Dec 15, 2019 6:35 pm, edited 5 times in total.
ryzen26OMEGALUL, gopal334, anti and 1 others liked this


@QuickTime, any chance you can share your EFI folder? I have the same board and it's being a PITA to get working. Many thanks!
Thank you so much, I've got Catalina 10.5.2 installed now on my Ryzen system :)

My task now is to start learning OpenCore instead of Clover, also, a weird predicament that my Windows 10 NVME drive will no longer boot. Bizarre. Live and learn! Thank you for getting me this far.
@fozteh, I had some issue with OpenCore seeing windows. My work around was putting Clover EFI on one of the SSDs I have, which can be seen by OpenCore, or I can boot to that Clover from BIOS. Then I boot Windows from Clover. I don’t use Windows regularly at all, so I’m just glad it works.

Congratulations for running Catalina 10.15.2!
I’m assuming sleep doesn’t work?

I swapped Vega 56 out for a RX 570. It behaves differently that the CPU fan and chipset fan still don’t stop, but GPU fan will stop on RX570, while Vega 56 fan will kick into high gear.
@QuickTime, you have read my mind regarding Clover, I was just about to give that a shot! I haven't tested sleep yet, but I have ordered a T919 that should be arriving today. I'm guessing as it's natively supported the network/bluetooth kexts might not be needed? I'm going to try and dive into Opencore today so that I know what I'm looking at, but everything seems pretty solid here.

Sleep is not working.
ryzen26OMEGALUL liked this
I have the exact same motherboard, 3600X and the 5700XT. My local hardware store has great return options, so I'm able to test the TP-Link Archer T6E PCI Express Adapter while waiting for a BCM94360CS2 fully supported PCI-E kit from Ebay, which has both bluetooth and Wi-Fi, as the T919.

Any new experiences or tips for the setup or something you'd add for a OpenCore novice?
@Brass Ensemble, nice! I think my favourite thing about having a hackintosh is just the process of building it and trouble shooting it. It's always good when it 'just works' but its interesting learning why things break. I've just plugged in the T919 and it's working fine, Wifi and bluetooth are working, I'm now going to try and remove the kexts I don't need and try and modify the OC plist. I think my only real realisation is that I wish I'd gone Gigabyte, and wish I'd gone intel, but tbh this Ryzen machine is working a lot better than my old intel Hack.
Interesting! How did you go about creating your serial number? I'm unable to wrap my head around that guide. I'm currently editing the kexts. Is there more I have to do as the only difference I have compared to yours is the 5700XT (natively supported) and the 3600X (which I assume is the same kext as yours or natively supported). The T6E is apparently natively supported OOB.
@Brass Ensemble, I kind of cheated for the serial and used Clover Configurator - go to SMBIOS, there's a little set of up and down arrows under 'check coverage' button, select the machine you want, randomise the serial number and smuuid a few times and then paste them into the plist. I wish I had a 5700XT! But my 590 is doing fine, Im installing a few games now and will see how it goes. Power wise it doesn't spin up at idle so Im really happy, over on my intel machine it would just spin constantly whether at load or idle. The T919 is great, I had a little bluetooth usb that wasn't great, so I figured that it would be the same with the T919 card but it's really smooth and responsive.

I tried removing some of the kexts for bluetooth and wifi that were no longer needed, and removing the entries from the plist but couldn't get a boot. So Im going to wait till Ive researched it a bit more, or as OC becomes a bit more mature Ill dive into it then. To be fair I did it when really tired so might give it another go over the weekend.

Thanks for your post! I'm looking into replacing a[…]

Hello! I've been trying to get my OpenCore configu[…]

Fail. Not worked for nvidia gtx 1070

Hi many thanks, would you be able to share your Bo[…]