Welcome to AMD OS X

Why not register now to gain full access.

I'm trying to install Catalina 10.15.1 onto my new PC, and am running into mem allocation errors on boot up.

I've followed the guide here and originally was using clover, and then switch to OC - with same results.

I've disabled a alot of devices in BIOS, and have removed all drives except for 2 NVME & the USB drive I'm trying with.

In my OC setup I have the following

SSDT_EC.aml (Created from clover DSDT dump by SSDTime-master)



boot-args is set to:
-v npci=0x3000 debug=0x100 keepsyms=1 agdpmod=pikera

I have tried with no slide specified, as well as calculating the slide from a memdump

I have tried with above 4G on and off, and have toggled DOCP memory profiles, and reset CMOS multiple times to try and get a better memory learning

As this is first time with AMD, I'm not sure if I'm missing something or what to do next.

Any help appreciated, thanks
Post Merged
Additional info: I also have working installs of 10.14.6 and 10.15.1 from my previous system and have them on another NVME drive in a USB enclose. I have been trying to boot a fresh install USB, as well as trying to boot the old working versions I had with the updated bootloader settings, and the result is the same - unable to allocate memory
Post Merged
I've been battling this for days, and it seems quite strange to me. Has anyone seen this been done on a Ryzen threadripper yet ?

I've seen the same possible issue on both OC and Clover. I looked into the memmap due to the unable to allocate error, and can see the following available range A000000 - 9F062FFF
Memmap crop.jpg
The full dump is attached at the bottom.

For the available range I calculated a slide value of 0x4F, and so put slide=80 in the boot args.

The strange thing is both clover and OC select this range with the slide set, however I still get an error that they can't allocate the memory even though it shows in the available range

Open Core Error
OC error - med.jpg
Clover Error
Clover Error - med.jpg
Not sure if I'm doing something wrong, or it's maybe an issue with threadripper and the current clover/OC or even the Asus Mobo.

Any comments, ideas, suggestions would be greatly appreciated, as it's driving me crazy

Thanks !
You do not have the required permissions to view the files attached to this post.


Hi many thanks, would you be able to share your Bo[…]

There's a "ryzenshine" thread on hear th[…]

I experience this problem as well with OpenCore o[…]

Alcid=5 is the answer. Put this in as boot arg and[…]