Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: gm0rk

Never had this issue with earlier releases of Mojave or Sierra.
But after upgrading from 10.14.5 to 10.14.6 the clock cycles goes very fast.
A minute in Mac now only takes 16 sek. Looks weird watching the system clock :)

Tried everything with busratio and tips I could find online but nothing helps.
But if I boot up on my old Sierra harddrive everything is normal.

Anyone knows what I can do to fix this?

System spec.
CPU Ryzen 7 1800x
MB: Asus Prime x370-pro
RAM: DDR4 G-Skill Flare X 3200MHz 32GB
HD: Samsung M2 Evo 960 512 GB


Remove" the tsc_init; grab tsc from msr" patch from your config.plist > Kernel and Kext Patches > KernelToPatch
Thank you very much!
Removed this from my config.plist and the everything was back to normal speed.

<string>xlnc - tsc_init - use TSC calculated from MSR</string>

They have also fixed it on github. https://github.com/AMD-OSX/AMD_Vanilla/tree/master/17h
Problem was that I didn't know that TSC was causing my problem. :lolno:
I've now inserted the corrected values from the patch.

Thanks again!
Hi gm0rk,

I have the same mainboard as you, an ASUS x370 Prime Pro and I am having issues with installing Mojave 10.14.6 using Vanilla AMD. I get no Networking in the installer, I tried SmallTree-Intel-211-AT-PCIe-GBE.kext and FakePCIID, as well as other KEXTs, but I still do not get network. Can you please let me know what Networking KEXTs are you using ?


Just checked on other install, not working.

@QuickTime , any chance you can share your EFI fo[…]

I had already ordered Intel components to build a […]

yes thats why I am using xfx rx580 for the instal[…]