Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#52290
Hello,

Managed to get a successful install this week after some hassle with OC and the installer. Visual artifacts everywhere and all. However I had a 10.14.5 installation I upgraded to 10.15.1. That installation had Clover (boooo) on it so I went and deleted that **** and put OC EFI folder on the partition once upgrade was done. Everything EXCEPT sleep works.

My previous 10.14.5 success post is here for ref: viewtopic.php?t=8899

I followed exclusively official OC docs: https://khronokernel-2.gitbook.io/openc ... top-guide/

And of course I used our official AMD OS X guide for more info: https://vanilla.amd-osx.com

I did get stuck on the .dsl/.aml file part of the OC docs and that's because the docs aren't that clear there. Basically, .dsl files are source code and you want COMPILED source code so that would be .aml files. Just read that section slowly and take your time with the docs. They're not hard, actually most of the info should be irrelevant to you, they're just dense with info and you might lose track.

Bios:
* Followed the OC docs with ONE crucial exception: Disabled above 4g decoding/memory. I could not boot with it enabled for some reason.

YOU DO NOT NEED ANYTHING ELSE. NO YOUTUBE VIDEOS. NO WEIRD DISTRO GUIDES.

What works
* Native Audio
* Bluetooth
* Wifi
* AirDrop
* Handoff
* USB 2.0 and USB 3.1
* Ethernet
* NVMe (both slots)
* Mic (Blue Snowball)
* Headphones (front and back panel)
* 1x HDMI and 1x DP monitors

What does not work
* Dynamic wallpapers (they have weird red stripes)
* Sleep (sleep is weird. my peripherals go out when I click "Sleep" button on Apple icon but CPU, GPU and fans are on. I tried replugging the keyboard and mouse and they just didn't light up. I had this one case where the computer went to sleep on its own and it woke up fine on mouse click. I might've literally dreamed this bc I was tired. I will do more testing with this and update the post.)

Kexts
* Lilu
* NullCPUPowerManagement
* SmallTreeIntel82576
* VirtualSMC
* SMCProcessor (not required, might not actually do anything)
* SMCSuperIO (not required, might not actually do anything either)
* AppleALC, layout 7
* WhateverGreen (crucial, DP aka my other monitor does not work without it. I know some don't need this anymore since Navi native support)

Other fixes
* For some reason I did not need to apply the USB fix this time: https://amd-osx.com/forum/viewtopic.php?t=4986

Drivers
* ApfsDriverLoader.efi
* FwRuntimeServices.efi
* HFSPlus.efi
* UsbKbDxe.efi
* VBoxHfs.efi
* VirtualSmc.efi

My benchmarks:

https://browser.geekbench.com/v5/cpu/557800

OpenCL:
https://browser.geekbench.com/v5/compute/230830

Metal:
https://browser.geekbench.com/v5/compute/230832


No Whatevergreen (these are just for testing. only the HDMI monitor worked):

https://browser.geekbench.com/v5/cpu/557715

OpenCL:
https://browser.geekbench.com/v5/compute/230783

Metal:
https://browser.geekbench.com/v5/compute/230787

Geekbench 4 (old):

https://browser.geekbench.com/v4/cpu/14906731
Last edited by arn0 on Sat Nov 16, 2019 4:27 am, edited 1 time in total.
amdpush liked this

 Advertising

Hi there! What about InDesign? Is there any versio[…]

Install 10.15.1 using clover with latest vanilla i[…]

I hope you don't mind me replying in English, sinc[…]

Good afternoon, I'm new here and i got here becau[…]