Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
I'm very happy and proud to announce you that I succeded to make my hackintosh !
He's alive ! ALIIIIIVE !

I made a microATX hackintosh with a asrock X570M pro4 an excellent MOBO !

Because this motherboard is not very expensive, has very good VRM, 2 M.2 slot AND :
- a M.2 NGFF slot to put a wifi/BT ngff card ! (Yes dude !)
Capture d’écran 2019-08-30 à 19.21.35.png
- a thunderbolt connector to put the thunderbolt AIC form asrock and add 2 thunderbolt 3 ports ! oh yeah !

And I took a Sapphire RX580 8gb nitro+, G.Skill trident Z RGB 3200Mhz CAS18 2x16Gb, a SF600 from Corsair, a DW1560.

What's working ?
For the moment everything is working !
Photoshop is working, illustrator, xcode, blender, sketch, youtube in 4K !

Maybe a little latency with the bluetooth but i can connect a magic mouse and magic keyboard without any problem !
the keyboard can't change the brightness of the screen and the sound ... but I think it's because my computer was plug to my TV

And I can't use a microphone (I don't know what to do ...)

for the DW1560, I'm using 3 kext brcmairportfixup, bluetoothinjector and brcmfirmwarerepo !

Have fun dudes !
You do not have the required permissions to view the files attached to this post.
Oz-man, TheRyzenGuy liked this


i tried 3 times and yes it works ;)
the 3600 is one of the most impressive CPU I have ever seen !
For about 200€ (and you can buy it for less than 200€ today), you have a CPU that crush a 9700K in applications !

And if you want something really powerful, you can take a 3700X and you have something better than the 9900K, I will buy this one or the new 3900 in 3-4 months.

And if you want a hackintosh equivalent to the most powerful imac pro, you take the 3900X (yes !)

I will put photos as soon as possible !
Need your help, please. I have same board, just not micro, I have full ATX, The X570 Pro4. It's identical though so your EFI & BIOS Settings would work with mine. I've tried & tried a fresh vanilla install with no luck. Please text me at 514-416-5160 or email me at [email protected] to help me, I will send you some crypto...you know...like Bitcoin? ANyway, please help! Thanks!
Not microphone...micro ATX...I had ASRock X570 Pro4 FULL ATX Mobo...You have ASRock X570m Pro4, "m" for "microATX" Doesn't matter now, I returned it & got a ASUS ROG B450-F Gaming. ASUS activated PCIe 4.0 on it's B450 & X470 Mobo's, so no reason to get X570 anymore. Update BIOS to run Ryzen 3700X & it activates PCIe 4.0 as well. I don't need SLI so X470 isn't important to me either. My ASUS ROG STRIX B450-F Gaming rocks the Ryzen 3700X with no issues, I can overclock the hell out of it, gREAT VRM...plus I have no issues with Ryzentosh, everything worked perfect first try AND I have PCIe 4.0 working on ALL PCIe x16 Slots & M.2 slots, not just the first one near top, ON ALL. So I don't need your help, thanks anyways.
manoueltiger wrote: Fri Aug 30, 2019 5:18 pm
for the DW1560, I'm using 3 kext brcmairportfixup, bluetoothinjector and brcmfirmwarerepo !

Have fun dudes !
You saved me :) Thanks :thumbup:
@n8dagr8 : sorry mate, I didn't understand ;). Happy to see that you resolve your problem ;)

@ KojiAiba :
no problem, I had some issues with bluetooth because the firmware didn't update, so I put brcmairportfixup , firmwaredata, bluetoothinjectoor et patchRAM2 instead.
I have a similar Asrock x570 board (Taichi). Are you able to use iMessage? I followed the vanilla guide, and everything (except onboard Intel AX200 wifi, but that was expected) seems to be working - except iMessage. I'm getting activation errors. I have signed into iCloud and the App Store without an issue.

Did you do anything special with your Clover settings? I'm curious what your config.plist and kext settings are?

@gbp27 , Try with this.

Use a different USB port. It's hanging on Still W[…]

Using Hackintool for USB Mapping?

Is there a downside to using Hackintool for USB ma[…]

you think u can help me too with my USB map pls ? […]