Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: xelio
Hello guys,
Like tons of you I'm stuck trying to install Mojave on these lovely 3rd gen Ryzen.
The config i'm using:
  • MOBO: MSI B450 Gaming Pro (Bios updated)
  • Ryzen 5 3600x
  • RX 580 8GB
  • Crucial Ballistix 8 gb 3000MHz
  • ...more irrilevant stuff...
Ok, i've followed the step by step on vanilla.amd-osx.com and i was happy like a baby when the boot continued automatically 🥰
I could also start the osx installation as new mac or by a time machine backup.
BUT, becasue we have a big BUT, after about 1 minut it freeze. :evil:

Anyone else get this issue?
I also tried removing or adding kext.
Post Merged
** UPDATE **
Issue resolved getting precompiled KEXTS instead of compiling by myself, dunno what i did wrong but don't care anymore :thumbup:


User avatar
by: jonathann
Thanks for sharing. I am having the same issue of freezing after booting up from USB successfully to MacOS Utilities. It will freeze after 10 - 20 sec.
I checked everything in BIOS following suggestions to turn off Serial port, etc, etc. Still not working.

Where did you get the precompiled KEXTS?

My hardware spec:
MOBO: MSI B450 Gaming Pro Carbon
CPU: Ryzen 7 2700x
RAM: Corsair Vengeance RGB Pro 16GB
Disk: 1TB Samsung SSD 970 EVO Plus M.2 NVMe
GPU: MSI Armour RX570 4GB

It gets everything except my Gen4 PCIe NVME drive […]

It looks like you messed up your config.plist rath[…]

What does your EFI layout look like? Is your confi[…]

Thanks all for the help! The problem was not cor[…]