Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: vajiter1488
Good Day!

I installed hackintosh (high sierra 10.13.6 (17G7024)) everything works with a bang, except for turning it off.

After pressing the shutdown button, a text appears on the monitor screen that looks like errors, and then the monitor screen goes blank, the hard drives are working, and the cooler on the processor also rotates, but at the same time, my computer does not turn off, but it reboots (considering the fact that FixShutdown is checked in the config.plist file). The only way to turn off the computer is to press the power button on the system unit, which is actually not very good. (I'm afraid for the failure of components, in particular hard drives). I began to look for ways to solve this problem, but all to no avail.

PC specifications:
1) Motherboard: Gigabyte GA-970A-DS3P (rev 2.0)
2)CPU: AMD FX-8300
3) Graphics card: GeForce GTX 1060 (3гб)
4) Audio: Realtek ALC892
5) Network: Realtek RTL8111
6)Clover 2.4k 4940

When turned off


After loading the operating system
Code: Select all
Anonymous UUID:       07EBF4A7-4710-E1A9-6D44-FB3871B0DCAE

Wed Aug 14 17:38:00 2019

*** Panic Report ***
panic(cpu 0 caller 0xffffff800086e2b1): "USB OPTICAL MOUSE[0x10000028b]::terminate(kIOServiceSynchronous) timeout\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.71.45/iokit/Kernel/IOService.cpp:2297
Backtrace (CPU 0), Frame : Return Address
0xffffff81e2de3960 : 0xffffff800026bf96 
0xffffff81e2de39b0 : 0xffffff8000395354 
0xffffff81e2de39f0 : 0xffffff80003875e4 
0xffffff81e2de3a60 : 0xffffff800021dfb0 
0xffffff81e2de3a80 : 0xffffff800026ba0c 
0xffffff81e2de3bb0 : 0xffffff800026b7cc 
0xffffff81e2de3c10 : 0xffffff800086e2b1 
0xffffff81e2de3c70 : 0xffffff8000871de7 
0xffffff81e2de3cf0 : 0xffffff7f81c34884 
0xffffff81e2de3d10 : 0xffffff7f824f0f2b 
0xffffff81e2de3d50 : 0xffffff7f824f0908 
0xffffff81e2de3db0 : 0xffffff7f824e5d8b 
0xffffff81e2de3df0 : 0xffffff7f824e8a8d 
0xffffff81e2de3e40 : 0xffffff800087eec5 
0xffffff81e2de3eb0 : 0xffffff800087ec6a 
0xffffff81e2de3ed0 : 0xffffff80002a5b74 
0xffffff81e2de3f40 : 0xffffff80002a56d5 
0xffffff81e2de3fa0 : 0xffffff800021d557 
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.9)[A922833C-F80C-38EC-ADD6-BAE7B07452C0]@0xffffff7f80a94000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[93B5E6D7-8F74-39E2-A9C6-6B25F334733D]@0xffffff7f81b4d000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[FB0D8863-27B6-39BE-889D-E4A32ED357F8]@0xffffff7f81b45000
            dependency: com.apple.iokit.IOUSBFamily(900.4.1)[2837DD62-F2B0-3357-A164-D44FEF6810E0]@0xffffff7f81bf7000

BSD process name corresponding to current thread: kernel_task
Boot args: -v npci=0x2000 slide=0 

Mac OS version:

Kernel version:
Darwin Kernel Version 17.7.0: Wed Apr 24 21:17:24 PDT 2019; root:xnu-4570.71.45~1/RELEASE_X86_64
Kernel UUID: A2B2C3B5-C3BF-3BD6-97E2-BD8CAFF51AEB
__HIB  text base: 0xffffff8000100000
System model name: iMac14,2 (Mac-27ADBB7B4CEE8E61)

System uptime in nanoseconds: 191643777997
last loaded kext at 87599726283: com.apple.filesystems.msdosfs	1.10 (addr 0xffffff7f81ce4000, size 69632)
loaded kexts:

Model: iMac14,2, BootROM, 8 processors, 3,32 GHz, 16 GB, SMC 2.15f7
Graphics: NVIDIA GeForce GTX 1060 3GB, NVIDIA GeForce GTX 1060 3GB, PCIe
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 933 MHz, Kingston, KHX1866C10D3/
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 933 MHz, Kingston, KHX1866C10D3/
Memory Module: BANK 2/DIMM0, 4 GB, DDR3, 933 MHz, Kingston, KHX1866C10D3/
Memory Module: BANK 3/DIMM0, 4 GB, DDR3, 933 MHz, Kingston, KHX1866C10D3/
Network Service: Ethernet, Ethernet, en0
PCI Card: NVIDIA GeForce GTX 1060 3GB, Display Controller, Slot-1
Serial ATA Device: KINGSTON SUV400S37120G, 120,03 GB
Serial ATA Device: ST2000DM008-2FR102, 2 TB
Serial ATA Device: ST500DM002-1BD142, 500,11 GB
Serial ATA Device: hp       CDDVDW TS-H653R
USB Device: USB Bus
USB Device: USB Bus
USB Device: USB Bus
USB Device: USB Bus
Thunderbolt Bus: 


Remove GenericUSBXHCI and replace it with this and try, https://files.amd-osx.com/XLNCUSBFix.kext.zip
vajiter1488 liked this
Shaneee wrote:Remove GenericUSBXHCI and replace it with this and try, https://files.amd-osx.com/XLNCUSBFix.kext.zip
I did what you said, the problem was not solved. The computer restarts rather than shutting down. The mouse inserted into usb 3.0 refused to work (before removal GenericUSBXHCI worked.P.S:now only works in usb 2.0). But at the same time the port is working (inserted a USB flash drive for verification).
Post Merged
Everyone is trying to solve the problem, but to no avail.
I think I'll give up soon. :(
Every day, turning off the PC by pressing a button on the system unit does not bring any pleasure. :crazy: :eh:
Oh this hackintosh. :mrgreen:
Post Merged
Solved the shutdown problem.
The problem was in the nvidia web driver and usb kext.
How did I solve the problem?
1. Removed the web driver NVIDIA;
2. Deleted Kext's: DummyUSBEHCIPCI, DummyUSBEHCIPCI, GenericUSBXHCI,USBInjectAll and replaced by XLNCUSBFix.
3. I replaced the video card NVIDIA GTX 1060 (3GB) with AMD RX580 (8GB);
In principle, everything! ;) :clap:
Intel vs Amd, please advice.

Hi guys, Probably this question has been asked al[…]

I booted into windows for that, For wifi on Ma[…]

I'm using the same MB For the network i'm using […]

Hi all! I'm trying to install Catalina 10.15.3 but[…]