Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: spykor
Hi guys,

My PC's configuration is:
Mobo: Gigabyte GA-990xa-ud3, CPU: FX-6300, RAM: 8BG, Graphics: Radeon HD 6770, several SSDs and HDDs

It currently run (on separate disks) Windows 10 Pro, Linux Manjaro and Sierra 10.12.6 beautifully. Especially as Hackintosh (Sierra 10.12.6) everything works except FaceTime (in keeps reporting that the Apple ID is not correct, even though the Apple ID is working fine with Apple Store and iCloud).

I have repeatedly tried to install Mojave (10.14.4.and 10.14.5). I am able to install the the OS on a SSD (254GB) and I start the configuration of the system. I pass through country and language selection but as soon as I reach the point of the Privacy screen and click on "continue" it reboots. Every time!

Anybody knows how to pass that point?

Any help will be appreciated.

Thanks in advance


User avatar
by: Shaneee
Read this post from XLNC on InsanelyMac, https://www.insanelymac.com/forum/topic ... nt-2658085
User avatar
by: spykor
I have repeatedly tried to follow the post from XLNC on InsanelyMac, https://www.insanelymac.com/forum/topic ... nt-2658085, but I cannot enter single user mode. When I insert the -s switch in the boot parameters of CLOVER and select to boot from the SSD Mojave (where I have installed the OS in the first phase) the system goes into an infinite loop. It keeps displaying those messages about "AppleUSB...." and some other stuff, just like it does during normal boot but now it never ends! I have been waiting up to one hour but it keeps going. If I remove the -s switch the system boots normally, but again I get stuck at the Data & Privacy screen!
Any ideas?

I must point out that I don't use a "fixed" open source Shaneee kernel. I am using the AMD Vanilla method (following the https://vanilla.amd-osx.com instructions) for creating the installer and apply the kernel patches for AMD CPU on the fly through CLOVER. So, I probably cannot use the various prelinked kernels mentioned in various comments to tackle the problem. I am asking for help in solving the Data & Privacy screen reboot problem, when one uses AMD Vanilla installer method.

I tried issuing blindly the commands mentioned by XLNC on InsanelyMac comment mentioned above but it did not lead me to the login screen. After I rebooted by presing the reboot button on the PC and booted into USB installer and selected to boot from "Install from macOS Mojave" (the part installed earlier onto SSD) to continue with setting up the system, the system comes back with the Apple logo and the progress line and after that it enters an infinite loop of displaying some messages and then the same messages again.
I finally renstalled Mojave on the SSD disk and I am at the same point I was before: reboot after I press "next" at the Data & Privacy screen!
Did anybody have any succes by following XLNC instructions to overcome the problem? How did he/she do it?
Because it seems to me that, by issuing a bunch of intricate commands blindly seems to only lead to a damaged installation. It would be very helpful if somebody has a more straightforward approach. Or, we could just forget that we'll ever move to Mojave, which is a shame.

I am not only asking for help. Here is my contribution to the Hackintosh community: Instructions on installing OS X Sierra 10.12.x onto a PC with Gigabyte 990xa-ud3 mother, FX-6300 CPU and Radeon HD6770 graphics card, https://kaneis.wordpress.com/2017/07/26 ... hics-card/ and instruction on installing OS X Sierra onto a Sony Vaio SVS13 Laptop, https://kaneis.wordpress.com/2017/05/07 ... -s-laptop/
User avatar
by: s1der
Hello spykor, hello all !
I'm exactly in the same situation an I don't find a solution to pass away this Privacy screen. I've tested the same things as writed upper with same results...
Did you found a way to fix it ?
Thanks a lot !
Anyone succeeded in resolving this?
User avatar
by: Shaneee
Mohammed Rizwan wrote:Hi,
Anyone succeeded in resolving this?
https://www.insanelymac.com/forum/topic ... nt-2658085
Thanks Shanee... :thumbup: :thumbup: :thumbup:
It worked. Update 2 works like charm..

I haven't tried this at first since many posted as not-working.
But after you replied, I thought to give it a try.

Will soon come up with my success story :wave:

Hello, I'm currently working with my 2700x RX580 1[…]

Sorry @djseban, I missed your reply! Yes, your kil[…]

Change SMBIOS to iMacPro1,1, KPs will be gone

@teseraph , If you're still having Bluetooth i[…]