Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#49837
Hi guys, I have been using the latest method with gibMacOs and I manage to successfully install the operating system, however, after rebooting, when you are supposed to start with the Installation Wizard, clover will not see the Hard Drive, it's as if AppleImageLoader.efi and HFSPLUS.efi were missing but they are in the drivers64UEFI foldfers.
Basically, I created the image using makeinstall and installed it to the USB driver. replaced the config.plist under CLOVER/EFI/CLOVER place the kexts under kexts/Other fakesmc already added by the script, nullCPUPoer, lilu, whatervergreen and realtek 8111 drivers. The hard drive used APFS no encryption, no case sensitive

 Advertising

#49847
Hi, I'm not sure but seems to me like your installation was not completed. Clover doesn't show drives unless there are installed boot loader.
I'd recommend to boot from your USB stick and try to repair the hard drive (In disk utility try the "First Aid" button). Maybe there are some terminal commands you can try to repair boot loader.
#49871
Hi, I had a similar issue with a hackintosh before where clover would not see the installed partition but the apfs drivers solved that issue.
You usually install Clover to the bootloader, but you can also install it to a small pendrive and boot from it, I have one in a 128mb usb drive, it boots all my intel hackintoshes but of course it hangs when I try to use it in my machine with Ryzen. So I wanted to create another clover usb boot drive just for AMD Ryzen CPUs. Having a backup drive to use to boot into osx can save your life when playing with kexts. I also have managed to boot from the USB clover boot drive, then used a vanilla created installer inside a Mac and it would work just fine as well.
Post Merged
not sure where the edit button is, one more thing I wanted to add, After following the latest guide and replacing all the files mentioned there I see that clovers boots in textonly instead of showing you the theme gui, tried using a different theme other than the embedded one and still get a text only screen. That's the only difference I notice when booting from the clover created by default and the one I have after replacing all the files mentioned in the guide here:

https://vanilla.amd-osx.com/
Post Merged
Ok, I just had success booting my install, the install was always complete but Clover would not see it. I recreated the USB installer according to the guide but instead of deleting all the drivers inside DriversUEFI64, I left them and only copied aptiomemoryfix.efi and hpfsplus.efi, left apfsdriverloader.efi instead of deleting it and putting AppleImageLoader.efi instead. Clover still looks crappy but now it sees all the partitions and is able to boot into them
Bluetooth at Login?

Hello everyone, Long time lurker first time poste[…]

Hi Is it able to sleep and wake properly? Thanks

Yes i have, and the error disappeared. did yo[…]

[email protected]: AppleUSBEHCI::RestartUSBBus: USBS[…]