Welcome to AMD OS X

Why not register now to gain full access.

#47730
Hey,

I'm trying to install Steam client on osx 10.14.4 and it wont install, just comes up with Illegal instruction 4 and then closes.
I've installed Microsft Office, Skype, Acronis, Origin and so on with no issues

I did notice in Origin it said for one of my games that the OS wasnt 64bit, not sure if that is a hint on whats going on?
I was under the impression that 10.14.4 had to be 64bit only?

Any help would be appreciated, thank you.
James

 Advertising

#47758
Ah yes so the clover patches method stops OPEM 32bit compatabilty and the steam installer is 32bit, but steam its self is 64bit.
I guess you could copy a preinstalled steam folder from another "Mac" and run it, but then i assume any 32bit games wouldn't run either.
The only other method i could get working was using Shanee's 10.14.1 kernel without the patches in clover, everything works fine then. :roll:
Maybe Shanee will make another kernel? Or is everything going to be Clover patches now? Seeming that 10.15 will be 64bit only, i guess Clover patches is the way to go.
#47927
@Joe FupaLord, @conromia, on this link you will find a version of steam that will install and run fine on the native patches.

To install it requires you to disable gatekeeper.
#47928
IOIIIO wrote:
Fri May 10, 2019 8:55 pm
@Joe FupaLord, @conromia, on this link you will find a version of steam that will install and run fine on the native patches.

To install it requires you to disable gatekeeper.
This worked. Your a legend

Hi, that sounds great. You've decided to install H[…]

Hi, I'm not sure but seems to me like your install[…]

Hi, you'd better tell us how do you prepare your b[…]

Hi, did you put your new config.plist and kexts in[…]