Welcome to AMD OS X

Why not register now to gain full access.

Hello everyone,

I will be soon attempting the guide done by Shaneee and thought I would post my specs here in case anyone has comments for me? I will of course keep you updated on the installation - see if I can bring something to the community. Stay tuned :D

CPU: Ryzen 5 2600X
GPU: XFX Radeon RX 580 8GB GTS XXX
RAM: Ballistix Sport LT 16GB DDR4 2666 MT/s
SSD: WD Blue 3D 500GB SSD M.2

Much appreciated on all the work done so far to make Mojave work!

Post Merged
So that did not last long :) I am stuck on the usual "Mediakit reports not enough space on device for requested operation. Operation failed." that a lot of people have had trying to reformat the disk... Will see what is the best workaround for this.

So I followed this guide viewtopic.php?t=6029 (thanks Shaneee / Camacorn). All went fine with the USB built. Just had some issues with the reformat of my drive but managed to go through it (see below). So far everything seems to work (10.14.3):

  • GPU automatically recognised
  • App store login
  • Ethernet is fine
  • Reboot is fine and Clover launches automatically
  • No lag or anything else strange

I confirm the following is not working :(

  • iCloud is not working (keeps running when logging in)
  • The sound from the monitor is working but looks like I can't change the volume directly on the mac.
  • Safari seems to work but it freezes when I click on 'Preferences'
  • Sleep mode does not work

I managed to install a Windows 10 on another partition of the same drive without issues. All went (very) smoothly. Even Clover has managed to keep up with the new Windows10 disc bootup without any manual updates :)

Hope that helps. Let me know if any questions!
Last edited by gotye on Fri Mar 15, 2019 2:50 pm, edited 11 times in total.


User avatar
by: gotye
Thanks for the tip. I was using the disk utility that comes up when booting from the USB. Looks like it was struggling formatting as APFS due to the fact it was a Windows 10 on it. I solved it by merging the two partitions (one small 500MB with the rest) and retried formatting APFS and it worked. If you have the same message click on 'Partition' from the disk utility and format the two separately or merge and try again. I only used the disk utility and nothing else so you should be good :)

System: Mojave 10.14.4 Motherboard: Gigabyte Aoru[…]

how did you get the bluetooth and wifi working? it[…]

stuck at root device UUID is....

amd 1700 msi b350 rx590 can use this config.pli[…]

Thanks! I'll try it later!