Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
User avatar
by: AlGrey
#44459
Did you even try to run the script.. Because DSDT is not patched nor is the config.plist..
newer71 wrote:
Tue Dec 11, 2018 1:00 pm
Exellent wrote:
Tue Sep 04, 2018 6:37 am
AlGrey wrote:@Exellent, Help and Problem Reporting
Attach the following files in a zip file:
- config.plist
- IORegistryExplorer dump (File -> save)
- DSDT.aml
Hi my files here.. usb not working.. pleese hhelpp

 Advertising

User avatar
by: wcg66
#44714
I downloaded the tools individually, just make sure you download the latest versions.
#44729
I previously used XLNC automated script to fix usb on Ryzen running HS 10.13.6. It recognised my Bluetooth device too. I ran the same script on Mojave 10.14.1 but Bluetooth is not showing. I have X370 Taichi motherboard and Ryzen 1700. I am not sure how to bring bluetooth to life? Any suggestion @AlGrey
User avatar
by: AlGrey
#44767
@innerd, should work now
#44997
The system now hangs at 1649: ATHR: Unknown locale: 21
Post Merged
System hangs
Post Merged
My system worked well and this patch screwed it all up! How do I reverse it?
Post Merged
I decided to do a complete reinstall, what a headache!
You do not have the required permissions to view the files attached to this post.
User avatar
by: creep3r
#45251
Hi, I have changed my setup as described in first post's manual method.
That fixed all panic crashes and fixed function of many new devices. Although no USB2.0 hub is working and neither is single front panel USB2.0 port.

I'm running 10.13.6, with motherboard which has 7x USB3.0 + 1x USB-C internal ports and 1x USB 3.0 + 1x USB2.0 connected from front panel.

@AlGrey Thanks for your work at first. Got few questions?
What in fact is changed in AppleUSBXHCI kext by that patch (..83FB02->..83FB11)? Is this changing port limit?
Are USB2.0 ports basically supposed to work?
Might be problem in contents of (patched) DSDT extracted via DPCIManager?

Any tips or links to know where I can continue digging? I suppose I need to tweak DSDT specific for my hw setup.

Thanks, cheers
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11

Ok Ill start making another one now haha @Shaneee[…]

We don't support that method of installing. Use th[…]

Stuck at Random Seed

I could not boot 10.14.6 installer. Had the same p[…]

Crash at installation screen

Hey guys! So I've been having problem installing A[…]