Welcome to AMD OS X

Why not register now to gain full access.

#52093
It is so good to see that AMD OSX can be available at the same day as Catalina got it's first public release !
I tried 10.15.0 with Clover after a few days and I got a success, then I switched to OpenCore with a fail on Clover by updating 10.15.1 Beta 2, and started to explore OpenCore and got RX 5700 working perfectly on macOS Catalina !
Thanks to the AMD OSX Community and I am happy to share my EFI for those who need !

I have updated to macOS 10.15.1 (Public Release)
(This EFI should work with 10.14.6 , 10.15 , 10.15.1 Beta and 10.15.1)

Issue with my current build :
- No Wifi / Bluetooth because I don't have one (I am looking for a WiFi Card, you may suggest me one !)
- Siri showing "Sorry, could you say that again"
- Sidecar, Airdrop, AirPlay NOT TESTED (Coz I don't have a wifi card)
- Tell me if u got one !

What does this EFI have :
- AMD 10.15.1 Vanilla Patches
- I am using VirtualSMC
- Intel & Realtek Ethernet Enabled
- AppleALC Audio (Layout-ID = 1) (u might need to modify this)
- Lilu & WhateverGreen (Currently the latest)
- NullCPUPowerManagement & etc

THE EFI FOLDER :
EFI.zip
U may want to use :
- OpenCore Configurator or Xcode (to edit config)
- Hackintool (get your Audio PCI Location and anything else)
Post Merged
Screenshot 2019-10-31 at 9.12.42 PM.png
AMD RYZEN 5 3600 (4.2Ghz)
MSI B450M MORTAR TITANIUM
Corsair H100i Platinum 240mm RGB Water Cooling
GSKILL AEGIS 3000 (C14) 32GB RAM
INTEL 760P 256G (for Hackintosh)
Samsung 970 Evo Plus 500G (for Windows)
Asus RX 5700 8G (Founder Edition)
Antec NeoEco Gold 650W Power Supply
Inwin 301c mATX Case (with Corsair LL120 RGB Fans)

OS: macOS Catalina 10.15.1 (using OpenCore 0.5.2)
You do not have the required permissions to view the files attached to this post.
Trevor30, Fob, tuancuong92 and 4 others liked this

 Advertising

#52095
is RX5700 natively supported?
#52097
pi2in3 wrote:is RX5700 natively supported?
It is on 10.15.1 yes.
#52120
i used OC EFI attached here and i have no Audio, i'm unfamiliar with OC , how can fix it?
RTL887 and using layout 3 in Clover
Egress liked this
  • 1
  • 2
  • 3
  • 4
  • 5
  • 7

Hello, I'm currently working with my 2700x RX580 1[…]

Sorry @djseban, I missed your reply! Yes, your kil[…]

Change SMBIOS to iMacPro1,1, KPs will be gone

@teseraph , If you're still having Bluetooth i[…]