Welcome to AMD OS X

Why not register now to gain full access.


Hello, i have successfully installed the HighSierraAMD V3 UNOFFICIAL and everything seems to be ok.
But when i tried to install Parallels Desktop, the screen turned black and then the computer restarted . Other than this, even i had successfully installed apps like Docker or Cuda, when i opened them, it always comes up many problems and failed finally.
It seems that when the computer are dealing with works related to 'Virtual Environment', problems comes. Can you helper me to fix this? Should I do something to my BIOS?
Post Merged
Sorry, i forgot to write down the features of my computer:
AMD 2600x 3.6Ghz
msi B450M pro-m2
8G ddr4 3000Mhz (2933Mhz actually)(I turned the XMP on)
Intel 760p 256G.
@Norton287, Ive followed your tutorial entirely but get stuck after using the preinstall. i get a notification stating "MacOS could not be installed on your computer"
i do have a 1tb ssd could this be the cause of my issues?
Post Merged
Hello, thank you for this comprehensive guide. I have been stuck after loading the preinstall and the installer says "MacOs could not be installed on your computer" could this be caused by using an ssd?
Thank you this is the only tut iv had a successful insall and boot im am little unsure how to update clover as when I DL the updated version I get a system wide clover bulid conflict but all in all great, even Xcode works but the only problem is this is a out dated virsion can I change the version number like on a jb ios device? If so is it best to do from tranmac or after in stall ? Will there be s update on this installer any time soon not trying to sound like a ETA kid but I have a dev account I would like to use to its full potential (thax) if anyone can help me out im more than happy to add there UDID and send them a p12 and profile so they can sign there own app on a serten 3rd party dl sight. Also have issues with that at the moment as im still learning, I can create on that works but will on sign one app after that the first is removed to sign that one ..... like I said any successful hellp ill reagester them afew devive IF YOU BULID ME A INSTALLER TO MY SPECK ILL SIGN 20 or so .... msg me on here or email me @ xxdang,,,,,[email protected],,,,k.

Just remove ,,,,, THAN YOU
I have succesfully installed High Sierra on my Ryzen machine (Ryzen 7 2700x, Gigabyte Aorus x470 and AMD 7850 graphics card), but I have SSD disk and during installation it was coverted to APFS filesystem, so I can boot only with USB. Please help, because video is not available, what to do, where to copy apfs.efi .

I have also question about what to do with boot0 error when I have APFS drive - I guess that I should dd of boot1h to EFI - disk0s1?

Guid partition scheme
EFI EFI disk0s1
Apple_HFS disk0s2

/dev/disk1 synthetised
APFS container disk1
APFS volume preboot disk1s2
APFS volume recovery disk1s3
APFS volume VM disk1s4

Post Merged
I have tried to install High Sierra AMD again on my SSD, I was succesfull to do it without APFS conversion:

1) boot from USB HighSierraAMD V3 UNNOFICIAL , partition disk as HFS Journaled - name it for example AmdOSX, Install OSX, reboot

2) boot from USB again, enter terminal, ls -la /Volumes, You can see AmdOSX, so cd /Volumes/AmdOSX, cd "macOS Install Data"

edit file minstallconfig.xml , so:

vi minstallconfig.xml

look for :

change it to:

save it with :x!

now continue with cd /Volumes/HighSierraAMD/

enter name of your disk: AmdOSX

and continue , reboot

3) now boot from AmdOSX, after installation reboot

4) boot from HighSierraAMD USB again, open terminal :

cd /Volumes/HighSierraAMD


and reboot

thats all

Now You have SSD without APFS, I can see EFI partition, but the disk won't boot, only with help of USB, I'm getting this error:

Reboot and select proper boot device ...

I tried to dd boot1h file on EFI partition, without success, I have tried to install Clover - install failed, I can not mount EFI partition with Clover Configurator - only with EFI Mount V3, I think that EFI partition is damaged, I will try to repair it.
Post Merged

I have read many forums, I have tried many things, absolutely nothing helped, just THIS:

- insert two USB keys into computer, one with HighSierraAMD V3 and another (HighSierraAMD with Enoch bootloader in my case)
- boot from second one
- open terminal
- diskutil list - lists disks, we have three Volumes, OSXDISK is for example disk0, that one with broken boot, disk1 is HighSierraAMD and disk2 is second USB we have booted from
- diskutil unmount /Volumes/HighSierraAMD , diskutil unmount /Volumes/OSXDISK
- now we are going to copy whole EFI partition from HighSierraAMD V3 to that broken one: dd if=/dev/disk1s1 of=/dev/disk0s1
- after some time, when it is done, reboot, now enter the bios and select disk with repaired boot to boot from
During the install, I am getting stuck at 15 minutes remaining.
Here is my error code:
NSLocalizedDescription = "An error occurred while extracting files from the package \U201cCore.pkg\U201d.";
NSURL = "Core.pkg -- file:///Volumes/InstallESD/Packages/OSInstall.mpkg";
NSUnderlyingError = "Error Domain=PKXARArchiveErrorDomain Code=101 \"archive verify failed\" UserInfo={NSURL=file:///Volumes/InstallESD/Packages/Core.pkg#Payload, NSFileOwnerAccountID=0, NSFileHFSTypeCode=0, NSFileSystemFileNumber=458, NSFileExtensionHidden=false, NSFileSystemNumber=16777248, NSFileSize=4450987435, NSFileGroupOwnerAccountID=0, NSFileOwnerAccountName=root, NSFilePosixPermissions=420, NSFileHFSCreatorCode=0, NSFileCreationDate=2018-01-19 14:03:30 +0000, NSFileType=NSFileTypeRegular, NSFileGroupOwnerAccountName=wheel,Dec 16 22:32:34 Mac-Pro OSInstaller[559]: OSIInstallElement <OSIInstallElement: 0x7fba0a4a4c30> errored out:Error Domain=PKInstallErrorDomain Code=110 "An error occurred installing macOS. To use Apple Diagnostics to check your Mac hardware, shut down, press the power button, and immediately hold the ‘D’ key until diagnostics begins." UserInfo={NSLocalizedDescription=An error occurred installing macOS. To use Apple Diagnostics to check your Mac hardware, shut down, press the power button, and immediately hold the ‘D’ key until diagnostics begins.}
Dec 16 22:32:34 Mac-Pro storagekitd[560]: Ejecting 1 disks
Dec 16 22:32:34 Mac-Pro storagekitd[560]: Ejecting SKDisk { BSD Name: disk24s1 Mount point: /Volumes/OS X Base System 1 Role: kSKDiskRoleLegacyMacData Type: kSKDiskTypeHFS }
Dec 16 22:32:34 Mac-Pro OSInstaller[559]: ------- Install Failed -------
  • 1
  • 12
  • 13
  • 14
  • 15
  • 16
  • 19
Bluetooth at Login?

Hello everyone, Long time lurker first time poste[…]

Hi Is it able to sleep and wake properly? Thanks

Yes i have, and the error disappeared. did yo[…]

[email protected]: AppleUSBEHCI::RestartUSBBus: USBS[…]