Page 12 of 19

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Tue Sep 25, 2018 7:12 am
by bradleylukecheung
my motherboard is x399 gigabyte aorus gaming 7, my CPU is threadripper 1900x, graphics card is vega64. I got this panic during booting, and I don't know what to do. please somebody help me, think you.

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Tue Oct 02, 2018 5:17 pm
by jynox
Norton287 wrote:
Mon Feb 26, 2018 2:36 pm
[info]If you have an SSD this will auto upgrade you to APFS, you need to follow Shaneees' tutorial here on APFS: http://forum.amd-osx.com/viewtopic.php?f=24&t=3453. You can find apfs.efi on the USB drive in EFI/Clover/driver64UEFI folder. If you're booting Legacy with no UEFI bios then you need to copy apfs.efi to USB/Clover/drivers64 folder. Follow this tutorial for mounting the USBs EFI partition: http://forum.amd-osx.com/viewtopic.php?f=24&t=3538.[/info]

To begin use Transmac to restore the HighSierraV3Unofficial.dmg file to a USB drive, the USB drive needs to be at least 8GBs in size. This tutorial by Shaneee covers using Transmac to restore dmg images to USB: http://forum.amd-osx.com/viewtopic.php?f=24&t=1213. Once you have the image restored you want to boot off the USB drive. You want to select HighSierraAMD to begin. If you get a Waiting on Root Device message, move the USB to a different port for a few seconds to see if the install continues. If it does not then keep moving ports until it does.


[info]BIOS Settings[/info]

Set your SATA ports to AHCI


Image


Enable USB Legacy support and EHCI handoff


Image



Disable your Serial Port

Image



Enable CSM and UEFI for Hard drives and USB devices


Image


Set Secure Boot to Other OS


Image

[info]Installation[/info]


Select your USB and hit enter

Image

Highlight Boot macOS from HighSierraAMD and press enter

Image

If this is a NEW install highlight Disk Utility and press Continue

Image

Select your Drive from the left side and click the Partition Button on the right to setup your new partition. You want to format it GUID/Extended Journaled.

Image


Once your new partition is created it will show up on the left side under the drive you created it

Image
Click on Reinstall macOS and click Continue


Image

Click Continue

Image


Click Agree


Image


Click Agree again


Image


Select your drive and click Continue


Image


It will begin copying files for a few minutes and restart


Image


Select your USB and press enter


Image


Select Boot macOS from HighSierraAMD


Image


Click Utilities and Open Terminal


Image

Enter cd /Volumes/HighSierraAMD at the prompt

Enter preinstall


Image


Enter your partition name you created earlier


Image


Once it's complete click the Apple Menu and choose Restart


Image


Select your USB drive and hit enter


Image


Select Boot macOS Install from YOURPARTITIONNAME


Image


Soon as it loads the UI it will begin the install, it can take between 20 to 45 minutes depending on your hardware


Image


Once install is finished it will restart


Image


Select your USB drive and press enter


Image


You want to select Boot macOS from HighSierraAMD


Image


Once the UI loads you want to select Terminal from the Utilities menu


Image

Enter cd /Volumes/HighSierraAMD at the prompt


You want to enter AMD at the prompt


Image



Enter in your partition name you chose earlier

Image


Once its done it will reboot


Image




Select your USB drive and press enter

Image



[info]For Radeon Video Cards you need to jump through some hoops to get them working[/info]


Follow the tutorial except for the third boot when you boot to your hard drive for the first time. You want to go to Options - Configs and choose the config_injectATI and add your FakeID to Options - Graphics Injector.





This tutorial will help you figure out your fake ID : http://forum.amd-osx.com/viewtopic.php?f=24&t=2976. This should get you to the desktop.


Booting to desktop

Choose Boot macOS from YOURPARTITIONNAME


Image


Choose your country and click Continue


Image



Choose your keyboard and click Continue


Image


Click Continue


Image


Click on No and click Continue


Image


Click Skip


Image


Click Agree


Image


Click Agree again


Image


Enter you Account information for Login


Image


Click Customize


Image


Click Continue


Image


Click Don't Use


Image


Select your Time Zone from the map


Image


Uncheck all and click Continue


Image


Enable or Disable Siri


Image


Finalizing your Install


Image





Image


If you don't have Clover installed here are some tutorials for different install types depending on your hardware and installation choices. You want to do this while booted off the USB to desktop. You can find the Clover EFI Installer in the Clover Files folder on the Installation USB or you can download Clover EFI from here:

[code]https://sourceforge.net/projects/cloverefiboot/[/code]

Clover Configurator is included on the Install USB in the Clover Files folder to use.

[info]Installing Clover[/info]


Installing Clover for UEFI


[youtube]xqEuzxCwLwA[/youtube]


Installing Clover Legacy Bios



[youtube]2V1hkYv3dvs[/youtube]



Installing Clover to a partition with no EFI


http://forum.amd-osx.com/viewtopic.php? ... 494#p31494


Install Extra drivers for Clover with Clover Configurator


[youtube]as76oudT9qc[/youtube]


Copying the Installers EFI over your Hard Drives EFI


[youtube]NtMkvNsCJH0[/youtube]


[info] Don't scroll through this and download the installer. Questions answered by this guide will not be answered![/info]

Download HighSierraAMD_V3 Unofficial

[code]http://bit.ly/2KfegS3[/code]
i got able to boot after all the installation passagess, but after the boot sequence from the driver named "osx" it won't post nothing, tryied also injecting ati drivers from clover options but nada, black screen after all the sequence

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Wed Oct 03, 2018 11:10 am
by harryharry
So I tried the V3 yesterday and it is the first version that worked for me. Everything fine except one thing. I am not able to instal drivers via Clover Configurator - I cannout mout EFI partition. When I click on "mount partition" nothing happens. I am booted in hard drive. Not in the installation USB. Any suggestions please?

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Thu Oct 04, 2018 12:03 am
by gersonaaronruiz
apple already released the source code until 10.13.6. Will we see a V4 soon?
https://opensource.apple.com/
I'm waiting for a version above 10.13.4 for my video card to work natively

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Thu Oct 04, 2018 5:03 am
by Iridescentery
this version works for me perfectly, now i am really looking forward the 10.13.6 version :thumbup: , any news that we could updates to 10.13.6 from current V3? Or maybe there would be a V4 let us re-install it?

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Fri Oct 05, 2018 5:04 pm
by inkoqnito
Hello,
I tried to download Highsierrav3 but got the following message:

Sorry, you can't view or download this file at this time.
Too many users have viewed or downloaded this file recently. Please try accessing the file again later. If the file you are trying to access is particularly large or is shared with many people, it may take up to 24 hours to be able to view or download the file. If you still can't access a file after 24 hours, contact your domain administrator.

Will the file be downloadable later again?

And is High Sierra working with Ryzen processors?

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Sun Oct 07, 2018 4:53 pm
by Husker84
Husker84 wrote:Hi @Norton287 !

I'm trying to install AMDHD v3 on a AMD R-464L apu, but it don't start after click on "boot macOS from... it maintains the screen black.
I run the "UEFI" boot, if I try the other without uefi, the mouse and the keyboard don't work.

What can I do? Any idea?

Thanks.
Anyone?
Thanks!

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL

Posted: Wed Oct 10, 2018 5:06 pm
by kingCosmo
Rebez wrote:
Mon Mar 12, 2018 6:38 pm
Greetings,
I can get to the Boot Loader screen but I can't get the Mac OS utilities screen. Verbose mode says "Does printf work??"
Please help :)
Just press enter after about 5 seconds :thumbup:
Post Merged
Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018
Successfully booted into clover from my USB (high sierra v3) and clicked boot into Mac os. After waiting a little I get a light grey screen with no apple logo, followed by a darker grey screen where I can move my mouse. Pls help thanks in advance :thumbup:

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Thu Oct 11, 2018 11:59 pm
by ItsGiuseppe
(I got a Ryzen 2600, MSI gtx 1050ti gaming X and 16 GB of RAM 3200MHz)
I installed successfully HighSierraAMD V3 and it works if I boot it from USB. I already installed clover and when I try to boot it from Clover it shows me white stop sign. Why?
(I need also intel dual band wireless-ac 3168 kext)

Re: Install and PostInstall of HighSierraAMD V3 UNOFFICIAL - Instructions Updated 5/8/2018

Posted: Fri Oct 12, 2018 9:27 pm
by dragan
Hi! Newbie here. I tried instaling high siera amd v3 and siera 10.12. but could not pass those loading black screens with all that weird stuff.
My pc is Ryzen 5 1600,radeon rx 560 oc 4gb. , asus b-350 plus, 16gb ram ddr4 3000 mhz corsair. Ive done everything by the book from transmac and bios settings, but still cant install.