Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: khaazyz
I have successfully installed Mojave 10.14.4 on my system using the vanilla tutorial on tis site, there are only two problems and I think they are linked together.
1. My System time is off a bit.
2.My video and audio isn‘t synced.
I have tried bootflag busratio=37 and AppleRTC but no change.

My system:

AMD Ryzen 7 2700x
32GB DDR4 RAM Corsair Vengeance LPX 2666MHz
AMD Radeon RX460 (4GB Gigabyte Version)
MSI B450 Gaming Plus
+external audio device

Thanks for any tips or solutions!


User avatar
by: rolleiflex
I just signed up to tell that I have the exact same problem. Same CPU, Ryzen 7 2700x. I tried busratio, I tried setting the FSB and clock speed from clover, neither has worked.

Likewise, vlc cuts sounds repeatedly every few seconds saying that it got too out of sync and it has to reset, videos on YouTube when Safari is used goes out of sync, and my clock speed is also too fast.

Does anybody have any solutions to this? I've tried everything on the Internet by now.
User avatar
by: Bal
have the same issue with Ryzen 7 2700x:
Video and audio run out of sync/stutter.

Tried a lot with VoodooTSCSync, removed OC, different CPU settings in Clover. I later want to use an external audio device but right now neither internal nor external is working.

Would be really glad for any help because i am really stuck and want to run video editing programs on it that right now are nightmares

Kexts used: VirtualSMC, AppleALC (tried also Voodoo), Lilu, NullCPUPowerManagement, RealtekRTL8111, VoodooTSCSync with IOCPUNumber 15
User avatar
by: [email protected]
System Time - open Date & Time and change time zone (also check your BIOS if it's set on the correct date & time as well).

you need to install AppleALC kext and add parameters to your specific sound codec. mine was ALC892, you need to which your soundcard/mobo uses.

as for your GPU, try running at lower resolutions first and compare with the higher ones (Retina), it may be your GPU can't run retina which is basically image doubling scaling, so a 1080p retina is 2160p packed into 1080p which makes the graphics crisper but more work for your GPU and VRAM.
Post Merged
rolleiflex wrote:I just signed up to tell that I have the exact same problem. Same CPU, Ryzen 7 2700x. I tried busratio, I tried setting the FSB and clock speed from clover, neither has worked.

Likewise, vlc cuts sounds repeatedly every few seconds saying that it got too out of sync and it has to reset, videos on YouTube when Safari is used goes out of sync, and my clock speed is also too fast.

Does anybody have any solutions to this? I've tried everything on the Internet by now.
had that problem with VLC as well before, try MPV player and see if it fixes it.
User avatar
by: Bal
time in the bios seems to be ok, also in windows videos play without problems. i tried with lowres Video output to monitor. Now I also disabled core performance boost because of this post: viewtopic.php?p=47122#p47122

Problem with youtube and vlc video playback remains.
But the time in macOS seems to run ok as far as i can tell. (i am not really shure if that was a problem in the first place on my system)

Is there anything else i need to add for AppleALC? I only added a alcid=28 bootflag. Any other parameters for the ALC892?
User avatar
by: rolleiflex
I've tried Lars' suggestions about audio a while ago thinking that it was a video / codec problem before.

These have been my steps to diagnosis so far, documented here.

Far as I can see, if you use anything that relies on native codecs, your video / audio will be out of sync. For example, VLC will be out of sync, and it'll be cutting every few seconds because it resets itself noticing that it got out of sync. That to most people looks like an audio issue (vlc cutting) but it doesn't seem to be — it's your whole system going 5% faster based on the CPU clock. You can see the cuts happening on VLC debug logs, it says it got too far out of sync and cuts it.

So far, these are the things that you can have trouble with:
- Safari, on YouTube (which uses the native codec)

These are the things that won't have that problem:
- IINA player (This works, I'm using this)
- MPV player (? not sure)
- Firefox or Chrome using their own codecs

It's also not a 'video feed falling behind' issue — I have a Radeon Vega 64, it's capable of driving 2x 8k displays (or something like that), it likely won't have trouble driving my 4k display. I suspect that video is running at the normal speed, governed by the GPU's own clock, while audio is using CPU's ~5% faster clock, which gets out of sync pretty fast.

These are the things I tried:
- All audio fixes I could find (before realising it's not an audio issue)
- Setting busratio to 37, 36, as boot flag, from the CPU tab in Clover (boot flag had no effect, setting it from the CPU tab caused the value read from the About pane to change, but otherwise no effect?)
- Setting FSB explicitly to 100,000, slightly higher, slightly lower values, no effect
- I had no overclock in place, but I went to my bios and tried to disable anything that I can find - it's basically flat 3.7ghz excluding core boost, (AMDs equivalent of turbo boost)

Things that I haven't tried yet:
- Disabling core boost, so that the processor runs at a fixed 37 busratio. My hypothesis for this one is that I noticed on the boot logs the turbo boost / up rate is shown as 0, so the OS sees the processor as incapable of turbo boosting. If the processor *still* turbo boosts on its own, that might be the reason the skew happens. That would also explain why busratio doesn't work.

I'll try this when I go home. If in the small chance this actually helps, I'll report back. However, even in the case this works, shutting off core boost is probably loses you some performance.

In short — we probably need some patches specific to 2700x, it seems. I'm a software guy, I would go at it myself but I don't really know where to start. If anyone has any ideas, happy to take a look.
User avatar
by: shuhung
Issue seems to be caused by odd CPU multiplier, CPU multiplier need to be even otherwise will cause video/audio sync issue.

For example, system detected maxratio is 72 (36x), but BIOS or CPU default setting is 37x
Final FSB equal to FSC 100 MHz x TSC 37x / maxratio 36x =102.777 MHz

If CPU base clock ratio is 37x and turbo is 43x, both are odd multiplier, in this case, disable core performance boost or add busratio flag will not help, need set multiplier to even number in BIOS, like 36x 38x 40x .... will solve this issue.

macOS Mojave 10.14.5 + vanilla patches
CPU: Ryzen 3 2200G
Graphics: Sapphire RX570 4GB VRAM
Mobo: ASRock B450M-Pro 4
Ram: 2x8Gb ADATA DDR4 2667Mhz
Audio: ALC892
[email protected] liked this
User avatar
by: rolleiflex
Holy ****. You fixed it!

For posterity, the fix is simple: you need to go to your BIOS (in my case, ASUS X470 Pro) and you set your CPU multiplier to 36x. This will also disable boost for you since giving it a fixed value makes it manually fixed to that one. I tried fixing it to 37x, which did not work, so it's not the core boost disable that makes it work, it's 36x. I suspect 38, 40x .. etc would still work, but I did not want to put extra load on my system, someone else might want to try those too.

As you mentioned, the system detects maxratio as 72 from the boot logs as well, I'm not sure how you get to 72 from 36, but it definitely did fix time, audio sync and video issues, and everything works as it should now. Thank you!

EDIT: Confirmed 38x also works. Also confirmed you don't have to disable core boost, and that setting a fixed ratio in BIOS does *not* disable core boost. It has a separate setting way deep somewhere that it is controlled by. I'm keeping it at 38x, core boost enabled.

EDIT: For people who might find this later and figure out whether this is applicable to them, my system is:

AMD Ryzen 7 2700x
G.SKILL TridentZ RGB Series 32GB (2 x 16GB) 288-Pin DDR4 SDRAM DDR4 3000
Asus x470 Pro
SAPPHIRE Radeon RX Vega 64
User avatar
by: shuhung
From Clover boot log:

Initial FSBFrequency is 50 MHz, maxratio is 72, equal to 50 MHz x 72 =3600MHz
Corrected FSBFrequency is 100 MHz, equal to max frequency 3600 MHz / 100 MHz =36x

Therefore CPU multiplier equal to initial FSB x maxratio / corrected FSB =36x

Video/audio sync issue is solved, but video stuttering issue, audio crackling issue, still need workaround.

I use DaVinci Resolve app as temporary workaround tools for crackling sound and video stuttering issues, launch DaVinci will instant cease both sound crackling and video stuttering issue, but crackling sound will back again within 15 minutes, need click and refresh DaVinci window each time.

DaVinci app launched:
Analog audio output work fine, no sound crackling.
RX4XX/5XX HDMI audio crackling partially fix, crackling sound on QuickTime and Safari, work fine on VLC, IINA, QuickLook.
User avatar
by: rolleiflex
Is there any chance your computer is trying to use an IGPU that does not exist? I have a normal MacBook Pro as well, and opening DaVinci resolve forces external GPU to activate.

For the sound, I have ALC1200s on my motherboard, it ended up largely working without any modification. If you can confirm HDMI sound works, it might be easier to get a motherboard with ALC1200, which seems to be the best supported of all sound cards. (Or an external sound device might also work, and much cheaper)

Hey there :) I wanna install Mojave on my PC. Im[…]

@Shaneee , Sorry dude... still didn't work. But I[…]

FX 4130?

The installer is a recovery medium. It'll downlo[…]

Which OS X is compatible to AMD A8 7600

Sierra, High Sierra, and Mojave. You can install o[…]