Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
#46082
Best of 5 runs: 36,571

GPU is reporting 300mhz max frequency, which is consistent with the benchmark.

RX 580's typically run at 4x+ this level:

https://browser.geekbench.com/v4/comput ... RX+580+mac

LuxMark seems to be running OpenCL reasonably fast:

13,000+ results, which is typical for an RX 580.

This is not consistent with the GPU frequency reported.

Any ideas?

I've tried turning on/off inject ATI, setting FakeIDs, etc. etc. Suspect this is maybe related to GPU fan throttling? Or the AMD driver itself?

Runs:
https://browser.geekbench.com/v4/compute/3753930

https://browser.geekbench.com/v4/compute/3754232

https://browser.geekbench.com/v4/compute/3754028

https://browser.geekbench.com/v4/compute/3754002

https://browser.geekbench.com/v4/compute/3753906

 Advertising

#46526
Problem one is you're comparing against native "Real" Mac's. Video performance will always be lower on a Hackingtosh. Just the nature of the beast. I've seen it on my Intel/GTX system. Even with with Nvidia native drivers. I doubt it's a bottleneck.
#46570
Are you normally getting less than 30% gpu performance? I'm used to 75-90%, but less than 30% implies something else is going on that may be configuration related. Did not have the same issue on High Sierra (scored like 130,000-147,000 on Geekbench 4 OpenCL on High Sierra.

Nvidia driver performance on hackintosh is a fairly well known issue, but this GPU should be pretty well supported, especially since it was working fine on High Sierra.

Looks like a vanilla kernel patch just came out, might try fiddling with that to see if it improves things. OpenCL code should not be running at 300mhz (minimum) frequency on an rx 580.
#46861
I recently responded to this post about radeon rx card discussing this issue. Have you looked into benchmarking with Valley yet to see how much it may differ in that as well?

Another thing is the use of Mojave, which does handle OpenCL differently than High Sierra and before. Also, I just think High Sierra is more refined for hackintoshing. Have you looked at the performance in High Sierra? It may be worth it to roll your macOS back if it does improve your performance.
#49653
Having the same issue on RX570, it can score to 120K on 10.13.6, but only 40K on 10.14.5 (SMBIOS set to iMac18,3 and iMacPro 1,1 same result)
Strangely my friend having similar hardware but using an Intel CPU can score normally to 120K on 10.14.5
Not sure if the problem only happened to AMD CPUs
#50469
Well, I have 2 hackintos, one with a z390 and a Core i9 9900K, and another my new build with a Ryzen 3900X with a X570 motherboard, and I tested in the two systems with my Radeon RX 570, and in the intel System, the score is 127000 points in geekbench, and in the ryzen the score is 40000 points, really low... yeah is a AMD Problem for sure, I am looking for info to fix this if it is possible... maybe something that we are missing... because I tested with Final Cut and Brucex test 5K and it take the same time that in my Intel machine... 15 seconds... but in games and in 3D sucks, I am testing with Premiere to look the performance...
#50481
joedub112 wrote:
Sun Mar 24, 2019 5:15 pm
Problem one is you're comparing against native "Real" Mac's. Video performance will always be lower on a Hackingtosh. Just the nature of the beast. I've seen it on my Intel/GTX system. Even with with Nvidia native drivers. I doubt it's a bottleneck.
That's is not true, in an Intel Hackintosh the video cards works a lot better than a real mac, because the Mac gpu versions are lite versions of the original gpu chips, I have a Intel hackintosh and the performance is a lot lot better, the problem is there is something, maybe a config we need to do to make the video cards works like in Intel Hackintosh with full power...

Keep in mind that there still some workarounds that we have to figure out still to make a Ryzen Hackintosh work well because there is no Apple Macs with Ryzen and that could bring problems.

I have a RX 570 in my Intel Hackintosh and it beats a RX 580 Pro from an iMac, because all Apple Macs suffer from thermal Throttling... all at all, and as I said it is not the same chip, is a lite one...

Ok cool, and do I have to add the kext folder that[…]

but my VEGA 56 also encountered the same error . […]

Crash at installation screen

Hey guys! So I've been having problem installing A[…]

Hmm weird. I'm using the lastest 17h but my OpenCL[…]