Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: gm0rk
#50421
Hi,

Never had this issue with earlier releases of Mojave or Sierra.
But after upgrading from 10.14.5 to 10.14.6 the clock cycles goes very fast.
A minute in Mac now only takes 16 sek. Looks weird watching the system clock :)

Tried everything with busratio and tips I could find online but nothing helps.
But if I boot up on my old Sierra harddrive everything is normal.

Anyone knows what I can do to fix this?

System spec.
CPU Ryzen 7 1800x
MB: Asus Prime x370-pro
RAM: DDR4 G-Skill Flare X 3200MHz 32GB
HD: Samsung M2 Evo 960 512 GB

 Advertising

#50428
Remove" the tsc_init; grab tsc from msr" patch from your config.plist > Kernel and Kext Patches > KernelToPatch
#50438
Thank you very much!
Removed this from my config.plist and the everything was back to normal speed.

<dict>
<key>Comment</key>
<string>xlnc - tsc_init - use TSC calculated from MSR</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SIsNrt2QAA==
</data>
<key>MatchOS</key>
<string>10.14.6</string>
<key>Replace</key>
<data>
TIkllt2QAA==
</data>
</dict>


They have also fixed it on github. https://github.com/AMD-OSX/AMD_Vanilla/tree/master/17h
Problem was that I didn't know that TSC was causing my problem. :lolno:
I've now inserted the corrected values from the patch.

Thanks again!
#52408
Hi gm0rk,

I have the same mainboard as you, an ASUS x370 Prime Pro and I am having issues with installing Mojave 10.14.6 using Vanilla AMD. I get no Networking in the installer, I tried SmallTree-Intel-211-AT-PCIe-GBE.kext and FakePCIID, as well as other KEXTs, but I still do not get network. Can you please let me know what Networking KEXTs are you using ?

Thanks,

Someone else on this forum had posted similar succ[…]

Agree...so far everything seems to be working fine[…]

Hello, thanks for your reply! I am afraid the USB […]

@fozteh , included EFI and latest updates