Welcome to AMD OS X

Why not register now to gain full access.

AFAIK, a Mojave 10.14.5 feature is that if one's hackintosh model is declared in config.plist as, e.g., iMac (27-inch, Late 2013), then a hackintosh without Internal Graphics cannot perform the required hardware decoding of JPEGs.

I've learned that the Mac (SMBIOS ?) model can be changed to one that does not have internal graphics, and then the external GPU will be used, and so problem solved.

I'd prefer not to change the Mac model, and instead want to use the solution provided by NoVPAJpeg.kext and, of course, Lilu.kext. I already use Lilu 1.3.6 (the latest release).

However... when I tried to use the latest release of NoVPAJpeg.kext - NoVPAJpeg-v1.0.0-built-with-Lilu-1.3.5-RELEASE.zip - my system crashed shortly after booting. I think this may perhaps be caused by the fact that NoVPAJpeg.kext was built with Lilu 1.3.5 and I am using Lilu 1.3.6.

MY REQUEST... can someone in the know please build a new release of NoVPAJpeg.kext, built against Lilu 1.3.6. This would bring things up to date, and hopefully solve the very irritating no JPEG decoding problem.

Thanks !


Why not just use Lilu 1.3.5 ?
It is the one I use and works fine with NoVPAJpeg-v1.0.0-built-with-Lilu-1.3.5-RELEASE.zip solving the preview JPEG problem.
I now notice this statement at the NoVPAJpeg repository ( https://github.com/vulgo/NoVPAJpeg )

NoVPAJpeg.kext is deprecated.
In case its functionality is needed, use WhateverGreen.kext and add the following boot arguments:
shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94

So, I tried that --> crash just after login.

Finally, I took your suggestion of using Lilu 1.3.5 and NoVPAJpeg, which seems to have solved the problem.

I will download Xcode and try to build NoVPAJpeg for Lilu 1.3.6, so that I can hopefully continue to keep pace with Lilu releases.
Post Merged
Perhaps I spoke too soon, since I've just had a crash that may be related to use of NoVPAJpeg and Lilu 1.3.5. The struggle continues.
Post Merged
To continue my monologue...

I built NoVPAJpeg.kext with Lilu 1.3.6 and so far so good. JPEGs display now and I haven't had any crashes yet.

Anyway, I'm uploading this build:
You do not have the required permissions to view the files attached to this post.

Having the same issue. Built this hackintosh speci[…]

Thanks so much for the response. I think I will […]

I have the same problem, when i boot from the USB […]

Hi everyone, i have successfully completed my Cata[…]