Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: Chrissb
Hi all!

I can't seem to find the answer and came across this amazing community! I'm new to the Ryzentosh world and actually have a Mac but prefer to run logic on my pc.

I successfully got Mojave on via clover and it's been great. However it keeps popping up that there is an update 10.14.5 so I found the GitHub page, copied the patches list and pasted it into my EFI / Clover folder / config file. I then do the installer of 10.14.5, it tried to install (with the progress bar) for about 1 min then just reboots with a load of text and goes back to clover boot list, use " boot Mac OS from Mac OS" but just loads up and still says 10.14.5 is available.

The GitHub page doesn't over anymore instruction other than replacing config file which I've tried too and knacked up my build and had to boot from usb again to get that sorted.

Any advice would be greatly appreciated as tried hard to make it work and not got a clue! :D

Post Merged
One other thought do I need to mount EFI disk via clover configurator and update the config file from there? Think I may have tried it again nothing seemed to change. is there a certain place you have to paste the patches in the config file? I've tried, top and bottom :?
Post Merged
I'm using text edit too if that's helpful to know. Trying to cover all bases
I know people looking at this might be like what a noob can't be bothered answering but would really value anyones time to help as can't seem to find an answer on the forum as it's all in code which is something I'm not great with. took me forever to get the clover usb boot working to even get Mac OS on in the first place. I used to have to press F8 or F11 to get boot menu up to choose mac os etc... now it come sup automatically, don't even know how I did that :lol:


User avatar
by: BoogerMan
Updating Macos shows another option in the Clover boot selection something like "Update Macos..." (forgot the exact string) but select this instead of your regular boot selection.
User avatar
by: Chrissb
@BoogerMan, Thanks for taking the time to reply really appreciate it, It doesn't give me an update option but an install option but that takes me to install like a fresh copy of Mac OS type thing (or is that what I need to do with it?)
Post Merged
and that install option is there all the time, nothing new comes up (plus it's just a black screen with a list of options I don't have the clover nice screen with images of disks etc.. so maybe that's why? If so how do I rectify that? thanks again so much!
User avatar
by: Shaneee
The install option shown in Clover after running the update for the first time is the update option. It'll boot the update installer and update to 10.14.5
Just make sure that you've got the patches in your config before booting it.
User avatar
by: Chrissb
Thanks so much again for the help. I tried it and didn’t work. It just goes back to same menu options. I’ve tried clicking install one again then it just crashes and restarts. If I boot macOS from macOS it loads as normal but still no update. I’ve copied and pasted patch files in config so a bit confused :?
Remove the macOS Install Data folder from the root of the drive and try again.
Chrissb liked this

Have you installed NullCPUPowerManagement.kext? In[…]

I have the same hardware with gtx 1060 graphics. A[…]

Not microphone...micro ATX...I had ASRock X570 Pro[…]

Specs: CPU: AMD Ryzen 9 3900x Motherboard: Asus […]